Subject: unresolved symbol problem !!!!

From: "ShubhaBrata Bose" <[email-masked]>
Date: Fri, 12 Dec 2003 05:51:53 -0000

Hi !!!

I've a problem in wrting a module, that some symbols are not exported
in the '/proc/ksyms' like printk().
My linux version is 9 kernel version 2.4.20.
So,how can I made this possible.Should I need to recompile my kernel
? or should I have to do some manipulations with the System.map file.

Please help!!!!

Thanks,
shubh,

---

From: Muli Ben-Yehuda <[email-masked]>
Date: Sun, 14 Dec 2003 13:05:49 +0200

> in the '/proc/ksyms' like printk().

In general, you want the kernelnewbies mailing list for this sort of
query. See http://www.kernelnewbies.org 

Now, why do you need the symbol to appear in /proc/ksyms?

> ? or should I have to do some manipulations with the System.map

Nope, this has nothing to do with System.map. Please elaborate on what
you're trying to do, either here or on kernelnbiews. 

Cheers, 
Muil 
-- 
Muli Ben-Yehuda
http://www.mulix.org | http://mulix.livejournal.com/

"the nucleus of linux oscillates my world" - gccbot@#offtopic