Subject: RE: [hackers-il] Re: Gems of the Technion [was Re: My Opinion about the Technion ]

From: "Ofir Carny" <[email-masked]>
Date: Mon, 3 Nov 2003 15:41:46 +0200

<shlomif>
Computer Science started out and was developed for formulating and
theorizing the programming and computing processes. The amount of research
in the field of CS was miniscule and isolated before the 20th century.
Programming is the practical implementation and realization of computer
science. There are pure theoreticans in any field, but I tend to respect
people who also like to see some discoveries materialized.
</shlomif>

Not true, computers were a by-product of computer science (or more accurately, the science of computation), Turing and Newman did their majority of work without them. Programming is at most, like light bulb replacement, a technical work, not a science. Computer science is called so for a reason. You don't go to the technion to learn how to program, there are adequate courses for that which do not require 3-4 years.

-------
=============================================================
Ofir Carny
Design engineer
Vidius Israel Ltd.   
Hasadna 13, Ra'anana, Israel
Telephone: +972 (9) 7439250 Ext. 211
Fax: +972 (9) 7439251
[email-masked]
http://www.vidius.com

PortAuthority(tm) Server 
Keeping Information Inside
=============================================================

This electronic mail transmission and any accompanying attachments contain confidential information intended only for the use of the individual or entity named above. Any dissemination, distribution, copying or action taken in reliance on the contents of this communication by anyone other than the intended recipient is strictly prohibited. If you have received this communication in error please immediately delete the E-mail and notify the sender at the above E-mail address.

---

From: Shlomi Fish <[email-masked]>
Date: Mon, 3 Nov 2003 15:57:58 +0200 (IST)

On Mon, 3 Nov 2003, Ofir Carny wrote:

> Not true, computers were a by-product of computer science (or more
> accurately, the science of computation), Turing and Newman did their
> majority of work without them.

Correct, but they were still inspired by the primitve computers of their
time. During that time there were already computers or computational
machines developed in Europe. And Babbage developed his analytical engine
a long time before Turing.

There's an English saying that "necessity is the mother of invention".
> Programming is at most, like light bulb
replacement, a technical work, not a science. Computer science is called so for a reason. You don't go to the technion to learn how to program, there are adequate courses for that which do not require 3-4 years.

Regards,

	Shlomi Fish

> To unsubscribe from this group, send an email to:
> [email-masked]
>
>
>
> Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
>
>

----------------------------------------------------------------------
Shlomi Fish        [email-masked]
Home Page:         http://t2.technion.ac.il/~shlomif/

An apple a day will keep a doctor away. Two apples a day will keep two
doctors away.

	Falk Fish