Subject: RE: [hackers-il] Help with lotus notes.

From: "Arik Baratz" <[email-masked]>
Date: Thu, 26 Jun 2003 18:56:18 +0300

> -----Original Message-----
> From: Tzahi Fadida [mailto:[email-masked]]

> Hi all,
> I have some side job, and i need some help from someone who 
> knows lotus notes.
> I have a computer with windows XP that is connected to an 
> active directory domain, and there is
> lotus notes installed on it.
> My job is to take it off the domain, and make it a stand 
> alone desktop. My question is, how does
> lotus notes performs authentication? if i take it off the 
> domain, could it be that it will stop
> working because it used the windows authentication mechanisms?
> 10x.

Lotus notes does not use Windows authentication.

On the Domino server, you define a certificate authority (during installation). Then, when you define a user, you have to take those users and "register" them. In fact, what this means is that you create a public/private key pair for these users.

This public/private key pair is stored in a file called by default 'user.id' - which you have to somehow take to the client's computer and tell the notes client to use this file to authenticate.

There is something which is relevant to Windows users. If the Windows username is identical to the username in the Domino server, Notes tries the Windows password first - but only if some component is installed.

I'm not an expert on Domino/Notes, I just had a run-in with it recently. There's a good web site, notes.net, where there's plenty of info. I find it hard to search, but maybe I was impatient.

-- Arik

**********************************************************************
This email and attachments have been scanned for
potential proprietary or sensitive information leakage. 

PortAuthority(TM)  Server 
Keeping Information Inside
Vidius, Inc. 
www.vidius.com
**********************************************************************

---

From: "Tzahi Fadida" <[email-masked]>
Date: Thu, 26 Jun 2003 22:12:43 +0200

Thanks for the reply,
I went over the documentation and it says they also authenticate LDAP which includes active
directory. the question remains, do i need to be logged in to the active directory to authenticate
against it?

p.s: When i open the software it requires a password, so is it an indication that it doesn't use
windows active diretory authentication? (because it doesn't enters automatically after you aready
logged in to the domain)

* - * - *
Tzahi Fadida
[email-masked]
Technion Email: [email-masked]
* - * - * - * - * - * - * - * - * - *

WARNING TO SPAMMERS:  see at http://members.lycos.co.uk/my2nis/spamwarning.html

> From: Arik Baratz [mailto:[email-masked]]
> Sent: Thursday, June 26, 2003 5:56 PM
> To: [email-masked]
> Subject: RE: [hackers-il] Help with lotus notes.
>
>
> On the Domino server, you define a certificate authority (during installation). Then,
> when you define a user, you have to take those users and "register" them. In fact, what
> this means is that you create a public/private key pair for these users.
>
> This public/private key pair is stored in a file called by default 'user.id' - which you
> have to somehow take to the client's computer and tell the notes client to use this file
> to authenticate.
>
> There is something which is relevant to Windows users. If the Windows username is
> identical to the username in the Domino server, Notes tries the Windows password first -
> but only if some component is installed.
>
> I'm not an expert on Domino/Notes, I just had a run-in with it recently. There's a good
> web site, notes.net, where there's plenty of info. I find it hard to search, but maybe I
> was impatient.
>
> -- Arik
>
> To unsubscribe from this group, send an email to:
> [email-masked]
>
>
>
> Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
>
>
>
>
>