Subject: RE: [hackers-il] Finished [was Re: Ongoing translation of "Joel onSoftware" "Rub aDub Dub"]

From: "Arik Baratz" <[email-masked]>
Date: Wed, 22 Oct 2003 12:09:10 +0200

A resend, in UTF-8. Ignore the piece about UTF-7 inside.

-- Arik

<<<
Various friends asked me if they could use FogBUGZ at their companies. The
trouble was, it had too many hardcoded things that made it a pain to run
anywhere other than on the original computer where it was deployed. I had
used a bunch of SQL Server stored procedures, which meant that you needed
SQL Server to run FogBUGZ, which was expensive and overkill for some of
the two person teams that wanted to run it. And so on.

I'm going to violate every nettiquate rule here and write in Hebrew. Don't shoot me, I'm sorry, I am using UTF-7, I have put my faith in the Unicode god.

מספר חברים שאלו אותי אם הם יכולים להשתמש בFogBUGZ בחברות שלהם. הבעיה היא שבקוד המקור הוכנסו יותר מדי פרטים בצורה קשיחה, כך שקשה להריץ אותו על מחשב אחר מזה שעליו הוא הותקן במקור. השתמשתי בכמה stored procedures יחודיים לשרת SQL Server, מה שאומר שיש צורך בשרת SQL Server כדי להריץ את FogBUGZ - יקר מדי ובזבזני מדי עבור חלק מהצוותים שרצו להריץ את התוכנה, ומנו שני אנשים. בעיות מעין אלה.
I intentionally avoided the use of "hardcoded", but I failed to translate "stored procedures" properly, maybe someone has a better suggestion. I opted for native Hebrew sounding text versus 1:1 translated text, for example I translated the word "overkill" to "בזבזני" - which is correct in this context.

-- Arik

---

From: Shlomi Fish <[email-masked]>
Date: Thu, 23 Oct 2003 17:08:35 +0200 (IST)

Hi Arik!

OK, I integrated some of your modifications of the paragraph into the main
copy. Thanks.

Regards,

	Shlomi Fish

----------------------------------------------------------------------
Shlomi Fish        [email-masked]
Home Page:         http://t2.technion.ac.il/~shlomif/

An apple a day will keep a doctor away. Two apples a day will keep two
doctors away.

	Falk Fish