Subject: RE: [hackers-il] Re: lgpl help with java

From: "Tzahi Fadida" <[email-masked]>
Date: Fri, 12 Sep 2003 14:11:08 +0200

hi all,
I wonder if you can help me understand what can i do with this license
SUN PUBLIC LICENSE Version 1.0
http://www.opensource.org/licenses/sunpublic.php

I found the javacvs library in netbeans and i wish to use it in a priprietery program i am writing
(can't do anything about that). can i do that?
if not, is it like LGPL and i can use an interface to it and keep it open?

10x.

* - * - *
Tzahi Fadida
MSc Student
Information System Engineering Area
Faculty of Industrial Engineering & Management
Technion - Israel Institute of Technology
Technion City, Haifa, Israel 32000
Email [email-masked]
Technion Email: [email-masked]
* - * - * - * - * - * - * - * - * - *

WARNING TO SPAMMERS:  see at http://members.lycos.co.uk/my2nis/spamwarning.html

> -----Original Message-----
> From: Shlomi Fish [mailto:[email-masked]]
> Sent: Tuesday, September 09, 2003 9:37 PM
> To: Tzahi Fadida
> Cc: [email-masked]
> Subject: RE: [hackers-il] Re: lgpl help with java
>
>
> On Tue, 9 Sep 2003, Tzahi Fadida wrote:
>
> > 10x!, its a lot of help.
> > i have another question. I asked the question because i and several others wish to
> request that the
> > OPCAT tool of OPM will be made open source.
> > However, there is another problem here. as i understand the OPM itself is patentedby
> the technion
> > and the creator said to me that you cannot write a software that uses that patent without his
> > permission.
> > so, in principal, it looks to me that if we convert OPCAT to gpl, and add an exception that the
> > patent can be used for non-commercial or profitable use then whoever will want to use
> the program or
> > branches or even draw it(OPM diagrams) on a paper for commercial use, will have to buy the use
> > rights from the technion.
> > however, there is a problem that comes to mind, if you releaseOPCAT under GPL does it takes away
> > your patent?
> >
>
> GPL poses some restrictions upon the patents the software that covers it
> can be encumbered by. IIRC, these patents need to be RAND ones, where rand
> is reasonable and non-discriminatory. Check:
>
> http://lists.w3.org/Archives/Public/www-patentpolicy-comment/2001Oct/0018.html
>
> So, you cannot do this with the GPL. You can however, release the software
> under a license that is a modified GPL one, without these clauses. This
> won't make it compatible with other GPL software, though. Or you can use
> an entirely different license altogether. It's your call.
>
> Regards,
>
> 	Shlomi Fish
>
> >
> > * - * - *
> > Tzahi Fadida
> > MSc Student
> > Information System Engineering Area
> > Faculty of Industrial Engineering & Management
> > Technion - Israel Institute of Technology
> > Technion City, Haifa, Israel 32000
> > Email [email-masked]
> > Technion Email: [email-masked]
> > * - * - * - * - * - * - * - * - * - *
> >
> > WARNING TO SPAMMERS:see at http://members.lycos.co.uk/my2nis/spamwarning.html
> >
> > > -----Original Message-----
> > > From: Shlomi Fish [mailto:[email-masked]]
> > > Sent: Tuesday, September 09, 2003 8:56 PM
> > > To: [email-masked]
> > > Subject: [hackers-il] Re: lgpl help with java
> > >
> > >
> > > On Tue, 9 Sep 2003, Tzahi Fadida wrote:
> > >
> > > > Hi all,
> > > > i need help with lgpl stuff with java.
> > > > i wanted specifically to ask, if i open a closed source proprietery software will i
> be able to:
> > > > 1. will i be the only one able to sell it?
> > >
> > > Actually, anyone would be able to sell it.
> > >
> > > http://www.gnu.org/philosophy/selling.html
> > >
> > > But since it is freely distributed it won't make sense for you or anyone
> > > else to sell it.
> > >
> > > > I mean, how does QT able to use open source libraries and still mandatorily sell their stuff
> > > > for commercial use.
> > >
> > > That's because Qt is distributed under the GPL and similar licenses. GPL
> > > cannot be integrated with proprietary software (and free software of
> > > incompatible licenses) without the copyright owner exempting you from it.
> > > Troll Tech (Qt's owner) is not selling the right to sell Qt, but to
> > > integrate it with software that will be later distributed.
> > >
> > > > 2. how much control would i have on the development process?
> > > >
> > >
> > > Technically, anyone would be able to take your code, fork it and create a
> > > competing project. (if copyleft, then he must put it under the same
> > > licensing terms). Practically, if you run a "Bazaar-style" development
> > > process, and listen to what your users and co-developers want, it isn't
> > > likely to happen.
> > >
> > > > an aside question, am i allowed to use LGPL libraries in a proprietery code?
> > >
> > > LGPL yes. GPL - no, unless you are the owner or was exempted from it by
> > > him.
> > >
> > > > and what if i want to only use parts of the code inside my owncode, is it allowed?
> > >
> > > If you copy and paste a relatively large LGPL code into your own code,
> > > then the file this code is in becomes LGPLed as well.
> > >
> > > > If not, if i create a class that use bits of code from LGPL and relase this class as
> > > LGPL but in the
> > > > proprietery software use an interface to that class without opening the code. is it allowed?
> > > >
> > >
> > > Anyone and anything can link to LGPL code without restrictions.
> > >
> > > Regards,
> > >
> > > 	Shlomi Fish
> > >
> > > > 10x.
> > > >
> > > > * - * - *
> > > > Tzahi Fadida
> > > > MSc Student
> > > > Information System Engineering Area
> > > > Faculty of Industrial Engineering & Management
> > > > Technion - Israel Institute of Technology
> > > > Technion City, Haifa, Israel 32000
> > > > Email [email-masked]
> > > > Technion Email: [email-masked]
> > > > * - * -* - * - * - * - * - * - * - *
> > > >
> > > > WARNING TO SPAMMERS:see at http://members.lycos.co.uk/my2nis/spamwarning.html
> > > >
> > > >
> > > >
> > > >
> > > > To unsubscribe from this group, send an email to:
> > > > [email-masked]
> > > >
> > > >
> > > >
> > > > Youruse of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
> > > >
> > > >
> > >
> > >
> > >
> > > ----------------------------------------------------------------------
> > > Shlomi Fish      [email-masked]
> > > Home Page:       http://t2.technion.ac.il/~shlomif/
> > >
> > > Writing a BitKeeper replacement is probably easier at this point than getting
> > > its license changed.
> > >
> > > 	Matt Mackall on OFTC.net #offtopic.
> > >
> > >
> > >
> > > To unsubscribe from this group, send an email to:
> > > [email-masked]
> > >
> > >
> > >
> > > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
> > >
> > >
> > >
> > >
> >
> >
>
>
>
> ----------------------------------------------------------------------
> Shlomi Fish        [email-masked]
> Home Page:         http://t2.technion.ac.il/~shlomif/
>
> Writing a BitKeeper replacement is probably easier at this point than getting
> its license changed.
>
> 	Matt Mackall on OFTC.net #offtopic.
>
>

---

From: Shlomi Fish <[email-masked]>
Date: Fri, 12 Sep 2003 14:34:00 +0300 (IDT)

> if not, is it like LGPL and i can use an interface to it and keep it open?

Reading from the license:

<<<
3.7. Larger Works.

You may create a Larger Work by combining Covered Code with other code not
governed by the terms of this License and distribute the Larger Work as a
single product. In such a case, You must make sure the requirements of
this License are fulfilled for the Covered Code.

This means you can integrate it into a larger work a la the LGPL. Whether
you can close the source requires further investigation.

Regards,

	Shlomi Fish

----------------------------------------------------------------------
Shlomi Fish        [email-masked]
Home Page:         http://t2.technion.ac.il/~shlomif/

An apple a day will keep a doctor away. Two apples a day will keep two
doctors away.

	Falk Fish

---

From: "Tzahi Fadida" <[email-masked]>
Date: Fri, 12 Sep 2003 16:38:17 +0200

I've looked around and most say that the SPL is fundementaly the same as MPL - mozilla public
license: http://www.mozilla.org/MPL/MPL-1.0-annotated-fs.html
I am still not convinced that i can:
example:
i have a proprietery project A.
i have an MPL or SPL project B.
i call from project A functions or procedures from B
i keep project A proprietery.
the end.

from the writings i understand that of course i am free to do the opposite like adding
proprietery code(if i own it) to the open sourece code, which doesn't help me.

> From: Shlomi Fish [mailto:[email-masked]]
> Sent: Friday, September 12, 2003 1:34 PM

---

From: Shlomi Fish <[email-masked]>
Date: Wed, 17 Sep 2003 17:30:48 +0300 (IDT)

> proprietery code(if i own it) to the open sourece code,

Actually, I'm pretty sure that the MPL can be used to linked against from
within proprietary products. Otherwise, the Mozilla XUL would not have
been such a viable option for cross-platform GUI programming.

Regards,

	Shlomi Fish

	Falk Fish