Subject: C books ?

From: "David" <[email-masked]>
Date: Fri, 10 Oct 2003 17:08:26 +0200

Hi all ,

I just started studying applied ICT at my local college and we are about to start learning C . I was wondering if you guys know any good books on C for beginners (up to an intermediate or advanced level if possible ) .

Thx in advance,

David 
Antwerp-Belgium

---

From: "Exodus" <[email-masked]>
Date: Thu, 9 Oct 2003 21:36:32 +0200

hey david
i hope this will be usefull it has some good ebooks for C
infact you can dig in the site a little and i am sure you will
find some usefull ebooks

Exodus.

---

From: "David" <[email-masked]>
Date: Fri, 10 Oct 2003 20:01:23 +0200

Can you send me the URL too plz ? ;-)

Thx in advance,

David
Antwerp-Belgium
  ----- Original Message ----- 
  From: Exodus 
  To: [email-masked] 
  Sent: Thursday, October 09, 2003 9:36 PM
  Subject: Re: [hackers-il] C books ?

  hey david

  Exodus.

        Yahoo! Groups Sponsor 

  To unsubscribe from this group, send an email to:
  [email-masked]

  Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.

---

From: "Exodus" <[email-masked]>
Date: Fri, 10 Oct 2003 00:53:20 +0200

oh lol
http://freebooks.by.ru/CandCpp.html

---

From: Shlomi Fish <[email-masked]>
Date: Fri, 10 Oct 2003 18:17:18 +0200 (IST)

On Fri, 10 Oct 2003, David wrote:

> Hi all ,
>
> I just started studying applied ICT at my local college and we are about
> to start learning C . I was wondering if you guys know any good books on
> C for beginners (up to an intermediate or advanced level if possible ) .
>

I learned C initially from the Turbo C++ 3.0 manual and it was the second
language I learned after BASIC. I still would not recommend it as a book
because it was quite brief and light on explanations.

In any case, Prof. Kimchi of the Technion has some book recommendations:

http://www.cs.technion.ac.il/users/yechiel/CS/Teaching.html

He recommends the Kerninghan and Ritchie book as well as "A Book on C". I
never really read them, so I can't first-hand evaluate them to you.

Regards,

	Shlomi Fish

> Antwerp-Belgium

----------------------------------------------------------------------
Shlomi Fish        [email-masked]
Home Page:         http://t2.technion.ac.il/~shlomif/

An apple a day will keep a doctor away. Two apples a day will keep two
doctors away.

	Falk Fish

---

From: Muli Ben-Yehuda <[email-masked]>
Date: Fri, 10 Oct 2003 22:57:03 +0200

> never really read them, so I can't first-hand evaluate them to you.

Kernighan and Ritchie is the only C book I ever felt the need to have
physically on my shelf. 'Nuff said. It's *the* book on C. It's slim,
too, which is nice in this era of computer books that can be bought by
the pound. 
-- 
Muli Ben-Yehuda
http://www.mulix.org

---

From: Oleg Goldshmidt <[email-masked]>
Date: 23 Oct 2003 09:21:14 +0200

> too, which is nice in this era of computer books that can be bought by

I agree, with the addition of "C, A Reference Manual" by Harbison &
Steele. I don't think I own anything else devoted to C, nor have I
seen anything I wanted or needed.

-- 
Oleg Goldshmidt | [email-masked]