Subject: The R Project for Statistical Computing

From: Omer Zak <[email-masked]>
Date: Sun, 30 May 2004 01:34:11 +0300

I need heavy statistical processing for a project, and found the R 
software (http://www.r-project.org/).  I succeeded in using it for 
simple tasks such as plotting and linear curve fitting.

However, I see I need some hand-holding to do more complex analysis.
Is there anyone in Israel who is already using R and has few free 
moments for holding my hand?
                                         Thanks,
                                              --- Omer
My opinions, as expressed in this E-mail message, are mine alone.
They do not represent the official policy of any organization with which
I may be affiliated in any way.
WARNING TO SPAMMERS:  at http://www.zak.co.il/spamwarning.html

---

From: "Tzahi Fadida" <[email-masked]>
Date: Mon, 31 May 2004 01:15:57 +0200

how is it with large matrices of data? or large arrays, depends on the
terminology.
by large I mean10000, 50000,100000 records.
I have data in text files which is 40mb which I need to analyze.
currently I plan to use matlab, unless there is something else(free like
gpl, lgpl).

Regards,
	tzahi.

> -----Original Message-----
> From: Omer Zak [mailto:[email-masked]] 
> Sent: Sunday, May 30, 2004 12:34 AM
> To: Hackers-IL
> Subject: [hackers-il] The R Project for Statistical Computing
> 
> 
> However, I see I need some hand-holding to do more complex 
> analysis. Is there anyone in Israel who is already using R 
> and has few free 
> My opinions, as expressed in this E-mail message, are mine 
> alone. They do not represent the official policy of any 
> organization with which I may be affiliated in any way. 
> ------------------------ Yahoo! Groups Sponsor 
> --------------------~--> 
> Yahoo! Domains - Claim yours for only $14.70 
> http://us.click.yahoo.com/Z1wmxD/DREIAA/yQLSAA/saFolB/TM
> --------------------------------------------------------------
> ------~-> 
> 
>  
> Yahoo! Groups Links
> 
> 
> 
>  
> 
>

---

From: Omer Zak <[email-masked]>
Date: Mon, 31 May 2004 09:51:13 +0300

> currently I plan to use matlab, unless there is something else(free like

So far I didn't try R on large data matrices.
It is GPLed, and is also an official part of the FSF GNU project.
                                              --- Omer
My blog is at http://www.livejournal.com/users/tddpirate/

---

From: Shlomi Fish <[email-masked]>
Date: Fri, 4 Jun 2004 16:41:06 +0300

> So far I didn't try R on large data matrices.

Well, I'm not sure that R is a suitable replacement for Matlab. R aims to be a 
substitute of S-plus, which is a statistical analysis program. There are a 
list of other programs like that here:

http://salstat.sourceforge.net/

(look in the right side-bar).

If you're looking for something to replace Matlab, you are better off with one 
of these:

1. octave - http://www.octave.org/ - mostly compatible with Matlab. Still 
incomplete.

2. scilab - http://scilabsoft.inria.fr/ - incompatible with Matlab, but 
there's a program to convert Matlab programs to it (but not vice-versa). 
Still incomplete in comparison to Matlab, but has a nice GUI interface. 

It is sourceware, but I'm not sure if it's entirely free-as-in-speech. (albeit 
the homepage links the word "Free" to the license) Its license is still 
usable.

3. PDL (short for Perl Data Language) - http://pdl.perl.org/
A package offering fast and compact tensor manipulation operations to Perl, 
similar to those provided by Matlab. Still incomplete.

There may be other packages like that, but I haven't had any experience with 
them, so STFW. I don't think there's anything quite like Matlab available yet 
as far as the availability of modules and add-ons is concerned. But if I 
understand Tzahi's needs, then he should be able to find something sufficient 
for them, that is open-source.

Regards,

	Shlomi Fish

-- 

---------------------------------------------------------------------
Shlomi Fish      [email-masked]
Homepage:        http://shlomif.il.eu.org/

Quidquid latine dictum sit, altum viditur.
        [Whatever is said in Latin sounds profound.]