Subject: lgpl help with java

From: "Tzahi Fadida" <[email-masked]>
Date: Tue, 9 Sep 2003 20:04:46 +0200

Hi all,
i need help with lgpl stuff with java.
i wanted specifically to ask, if i open a closed source proprietery software will i be able to:
1. will i be the only one able to sell it?
I mean, how does QT able to use open source libraries and still mandatorily sell their stuff
for commercial use.
2. how much control would i have on the development process?

an aside question, am i allowed to use LGPL libraries in a proprietery code?
and what if i want to only use parts of the code inside my own code, is it allowed?
If not, if i create a class that use bits of code from LGPL and relase this class as LGPL but in the
proprietery software use an interface to that class without opening the code. is it allowed?

10x.

* - * - *
Tzahi Fadida
MSc Student
Information System Engineering Area
Faculty of Industrial Engineering & Management
Technion - Israel Institute of Technology
Technion City, Haifa, Israel 32000
Email [email-masked]
Technion Email: [email-masked]
* - * - * - * - * - * - * - * - * - *

WARNING TO SPAMMERS:  see at http://members.lycos.co.uk/my2nis/spamwarning.html

---

From: Shlomi Fish <[email-masked]>
Date: Tue, 9 Sep 2003 21:55:36 +0300 (IDT)

> 1. will i be the only one able to sell it?

Actually, anyone would be able to sell it.

http://www.gnu.org/philosophy/selling.html

But since it is freely distributed it won't make sense for you or anyone
else to sell it.

> I mean, how does QT able to use open source libraries and still mandatorily sell their stuff

That's because Qt is distributed under the GPL and similar licenses. GPL
cannot be integrated with proprietary software (and free software of
incompatible licenses) without the copyright owner exempting you from it.
Troll Tech (Qt's owner) is not selling the right to sell Qt, but to
integrate it with software that will be later distributed.

> 2. how much control would i have on the development process?

Technically, anyone would be able to take your code, fork it and create a
competing project. (if copyleft, then he must put it under the same
licensing terms). Practically, if you run a "Bazaar-style" development
process, and listen to what your users and co-developers want, it isn't
likely to happen.

> an aside question, am i allowed to use LGPL libraries in a proprietery code?

LGPL yes. GPL - no, unless you are the owner or was exempted from it by
him.

> and what if i want to only use parts of the code inside my owncode, is it allowed?

If you copy and paste a relatively large LGPL code into your own code,
then the file this code is in becomes LGPLed as well.

> proprietery software use an interface to that class without opening the code. is it allowed?

Anyone and anything can link to LGPL code without restrictions.

Regards,

	Shlomi Fish

> * - * -* - * - * - * - * - * - * - *
>
> WARNING TO SPAMMERS:see at http://members.lycos.co.uk/my2nis/spamwarning.html
>
>
>
>
> To unsubscribe from this group, send an email to:
> [email-masked]
>
>
>
> Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
>
>

----------------------------------------------------------------------
Shlomi Fish        [email-masked]
Home Page:         http://t2.technion.ac.il/~shlomif/

Writing a BitKeeper replacement is probably easier at this point than getting
its license changed.

	Matt Mackall on OFTC.net #offtopic.