Subject: LGPL copyrights addition

From: "Tzahi Fadida" <[email-masked]>
Date: Tue, 30 Sep 2003 09:19:06 +0200

I have created a file which uses bits of code from an LGPL project.
obviously i will have to make this file also LGPL.
how should i add my own or my organization copyright to the heading, and besides
releasing the code on our site, am i obligated to do anything else?
here is the old copyright note from the original file:
/*
** Java cvs client library package.
** Copyright (c) 1997-2002 by Timothy Gerard Endres
**
** This program is free software.
**
** You may redistribute it and/or modify it under the terms of the GNU
** Library General Public License (LGPL) as published by the Free Software
** Foundation.
**
** Version 2 of the license should be included with this distribution in
** the file LICENSE.txt, as well as License.html. If the license is not
** included	with this distribution, you may find a copy at the FSF web
** site at 'www.gnu.org' or 'www.fsf.org', or you may write to the Free
** Software Foundation at 59 Temple Place - Suite 330, Boston, MA 02111 USA.
**
** THIS SOFTWARE IS PROVIDED AS-IS WITHOUT WARRANTY OF ANY KIND,
** NOT EVEN THE IMPLIED WARRANTY OF MERCHANTABILITY. THE AUTHOR
** OF THIS SOFTWARE, ASSUMES _NO_ RESPONSIBILITY FOR ANY
** CONSEQUENCE RESULTING FROM THE USE, MODIFICATION, OR
** REDISTRIBUTION OF THIS SOFTWARE.
**
*/

* - * - *
Tzahi Fadida
MSc Student
Information System Engineering Area
Faculty of Industrial Engineering & Management
Technion - Israel Institute of Technology
Technion City, Haifa, Israel 32000
Email [email-masked]
Technion Email: [email-masked]
* - * - * - * - * - * - * - * - * - *

WARNING TO SPAMMERS:  see at http://members.lycos.co.uk/my2nis/spamwarning.html

---

From: Gilad Ben-Yossef <[email-masked]>
Date: Tue, 30 Sep 2003 14:27:05 +0300

On Tuesday 30 September 2003 10:19, Tzahi Fadida wrote:
> how should i add my own or my organization copyright to the heading, and
> besides releasing the code on our site, am i obligated to do anything else?

It very much depends on how the file is used:

Is it a seperate dynamic library or equivilent?
If so then you're done.

Is it statically linked library or equivilient inside a bigger piece?
Then you need to supply at closed binaries of the rest of the project so that 
it can be relinked with newer versions of the free module as well.

Is it hard coded as a non seperate part of a bigger work? 
Then you can't ship the bigger work unless it is under the LGPL itself.

In any case - you should really ask a lawyer that known about IP laws these 
questions. I am not one, this is not legal advice yada yada yada...

Gilad
-- 
Gilad Ben-Yossef <[email-masked]>
Codefidence. A name you can trust (tm)
http://www.codefidence.com

---

From: "Tzahi Fadida" <[email-masked]>
Date: Tue, 30 Sep 2003 15:39:09 +0200

everything that has code that was under the LGPL i am going to release under
LGPL, the question is, what should i write that will explain that i just added
some lines or taken portions from another project.
One file i updated and i want to write that i edited it.
and One file is a completely new file that uses binaries(java .class files) from
the original LGPL project and is statically linked and in this files i used
portions of code from the LGPL library. i want to add my copyright to the
original LGPL statement without impairing the original writer.

i was thinking along the line tal suggested:
/*
** Portions Copyright (C) 2003 by Tzahi Fadida, Technion
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

> -----Original Message-----
> From: Gilad Ben-Yossef [mailto:[email-masked]]
> Sent: Tuesday, September 30, 2003 1:27 PM
> To: [email-masked]; Tzahi Fadida
> Subject: Re: [hackers-il] LGPL copyrights addition
>
>