Subject: Tweaking the visual studio toolchain

From: omer mussaev <[email-masked]>
Date: Sun, 26 Dec 2004 04:17:04 -0800 (PST)

Hello,

I wonder if someone has experience in calling gnu
makefieles from Visual Studio - in parrallel with
running  the standard VS builds.

My problem follows: 

The software I work on has to work on 2 platforms:
custom board based on PowerPC G4 (built using gcc
cross compiler) and an emulator for the board, based
on Windows CRT.

Naturally, the software has to be built twice. Since
this time my primary working environment is Visual
Studio 6, I'd like to have the gcc called from the
Visual Studio. 

I wonder if anyone had tried an unholy marriage as
this before. Since I have really many visual studo
workspace files as a legacy, I'd like not to have to
rewrite all my VS projects from scratch as makefiles. 

What do you say?

=====
--
o.m.

__________________________________ 
Do you Yahoo!? 
Dress up your holiday email, Hollywood style. Learn more. 
http://celebrity.mail.yahoo.com

---

From: Arik Baratz <[email-masked]>
Date: Sun, 26 Dec 2004 14:32:15 +0200

On Sun, 26 Dec 2004 04:17:04 -0800 (PST), omer mussaev
<[email-masked]> wrote:

[snip]

> Studio 6, I'd like to have the gcc called from the

I once wrote a compiler, which used Bison and Flex. In VS6, you can
specify a custom build option for files, and these command are
supposed to return 0 on success. Specify custom build options using
GCC for your code.

Perhaps there's a better way, but I don't know it.

Maybe you can specify a dummy file, for which the custom build command
would be to run

nmake -f Makefile

(which is supposed to work on regular Makefiles)

-- Arik