Subject: Digital Whisper issue #1

From: Moshe Ben Abu <[email-masked]>
Date: Sat, 3 Oct 2009 17:07:22 +0200

Hello there,

Digital Whisper is a new Israeli security\hacking\programming web magazine
founded by Afik Castiel and Nir Adar, written in Hebrew.

Their first issue is out, you can grab a copy here:
http://www.digitalwhisper.co.il/issue1<http://www.linkedin.com/redirect?url=http%3A%2F%2Fwww%2Edigitalwhisper%2Eco%2Eil%2Fissue1&urlhash=QUvK&_t=disc_detail_link>

If anyone is willing to contribute, submit an article or give a feedback,
contact Digital Whisper crew here - [email-masked]

-- 
Trancer
Recognize-Security
http://www.rec-sec.com

---

From: Shlomi Fish <[email-masked]>
Date: Sat, 03 Oct 2009 17:39:15 +0200

Hi Moshe!

Thanks for the initiative and your effort, and good luck.

On Saturday 03 Oct 2009 17:07:22 Moshe Ben Abu wrote:
> http://www.digitalwhisper.co.il/issue1<http://www.linkedin.com/redirect?url
> =http%3A%2F%2Fwww%2Edigitalwhisper%2Eco%2Eil%2Fissue1&urlhash=QUvK&_t=disc_
> detail_link>

For some reason this URL passed through linkedin and yielded a 404. I used 
this URL, which I had to copy-and-paste manually:

http://www.digitalwhisper.co.il/issue1

A few notes:

1. Why are the articles in PDF format? PDF suffers from poor accessibility, 
inconvenience, low ability to be hacked and re-used, and other problems.
I don't have a PDF viewer configured in my browser, and when clicking on the 
link, one of them was downloaded to my hard-disk, and I am too inconvenienced 
to open it using a PDF viewer.

2. "Privilege Excalation" should be "Privilege Escalation".

3. It seems that with large enough fonts, the username and password fields 
overflow the left side-bar.

4. The comments should have self-links for anchors (e.g: 
http://www.digitalwhisper.co.il/issue1#comment5 )

> contact Digital Whisper crew here - [email-masked]

I'll consider it, thanks.

Regards,

	Shlomi Fish

-- 
-----------------------------------------------------------------
Shlomi Fish       http://www.shlomifish.org/
Stop Using MSIE - http://www.shlomifish.org/no-ie/

Chuck Norris read the entire English Wikipedia in 24 hours. Twice.

---

From: Moshe Ben Abu <[email-masked]>
Date: Sat, 3 Oct 2009 18:09:30 +0200

Thanks for the feedback, I've sent it to the authors.
What kind of format you suggest the magazine should be..?

On Sat, Oct 3, 2009 at 5:39 PM, Shlomi Fish <[email-masked]> wrote:

> ------------------------------------
>
> Yahoo! Groups Links
>
>
>
>

-- 
Trancer
Recognize-Security
http://www.rec-sec.com

---

From: Shlomi Fish <[email-masked]>
Date: Sat, 03 Oct 2009 20:02:29 +0200

> What kind of format you suggest the magazine should be..?

HTML or XHTML preferably. Possibly with some help from CSS, MathML, SVG, PNG, 
etc.

Note that you can create the magazine in various formats (including XHTML , 
PDF and even MS Word) using such technologies as:

http://www.shlomifish.org/philosophy/computers/web/choice-of-docs-formats/

Regards,

	Shlomi Fish

-- 
-----------------------------------------------------------------
Shlomi Fish       http://www.shlomifish.org/
Understand what Open Source is - http://shlom.in/oss-fs

---

From: Omer Zak <[email-masked]>
Date: Sun, 04 Oct 2009 09:42:06 +0200

In my opinion, PDF format is a fine choice, and I'd advise it to be
first choice for fully sighted people.
For people with special needs, do provide also a HTML/XHTML version, as
suggested by Shlomi.

                                        --- Omer

-- 
"Kosher" Cellphones (cellphones with blocked SMS, video and Internet)
are menace to the deaf.  They must be outlawed!
(See also: http://www.zak.co.il/tddpirate/2006/04/21/the-grave-danger-to-the-deaf-from-kosher-cellphones/ and http://www.zak.co.il/tddpirate/2007/02/04/rabbi-eliashiv-declared-war-on-the-deaf/)
My own blog is at http://www.zak.co.il/tddpirate/

My opinions, as expressed in this E-mail message, are mine alone.
They do not represent the official policy of any organization with which
I may be affiliated in any way.
WARNING TO SPAMMERS:  at http://www.zak.co.il/spamwarning.html

---

From: Shlomi Fish <[email-masked]>
Date: Sun, 04 Oct 2009 17:47:06 +0200

> first choice for fully sighted people.

Why? Show me your reasons! In the previous message, I've given several reasons 
for its problematic nature:

<<<<<<<<<<<<<

Please offer a rebuttal for them.

> For people with special needs, do provide also a HTML/XHTML version, as

I am not sight-impaired but I also prefer HTML/XHTML due to the advantages 
above. A PDF version unnecessarily inconveniences me.

Regards,

	Shlomi Fish

> > HTML or XHTML preferably. Possibly with some help from CSS, MathML, SVG,
> > PNG, etc.
> >
> > Note that you can create the magazine in various formats (including XHTML
> > , PDF and even MS Word) using such technologies as:
> >

-- 
-----------------------------------------------------------------
Shlomi Fish       http://www.shlomifish.org/
Optimising Code for Speed - http://shlom.in/optimise

---

From: Dotan Cohen <[email-masked]>
Date: Sun, 4 Oct 2009 13:09:51 +0200

> to open it using a PDF viewer.

I actually think that PDF is great. It is freely available, preserves
formatting across OS / applications, and is contained in a single file
([X]HTML is not). Is is searchable and the text is extractable. Is is
also accessible to the disabled, though Linux support for that feature
may be missing (a problem with Linux applications, not with PDF
itself). There are RTL issues with PDF though.

>> contact Digital Whisper crew here - [email-masked]

When I get around to it!

-- 
Dotan Cohen

http://what-is-what.com
http://gibberish.co.il

---

From: Shlomi Fish <[email-masked]>
Date: Mon, 05 Oct 2009 16:25:51 +0200

On Sunday 04 Oct 2009 13:09:51 Dotan Cohen wrote:
> > 1. Why are the articles in PDF format? PDF suffers from poor
> > accessibility, inconvenience, low ability to be hacked and re-used, and
> > other problems. I don't have a PDF viewer configured in my browser, and
> > when clicking on the link, one of them was downloaded to my hard-disk,
> > and I am too inconvenienced to open it using a PDF viewer.
> 
> ([X]HTML is not). 

The latter can be solved using solutions such as .zip or tar.gz or a CHM :

http://en.wikipedia.org/wiki/Microsoft_Compiled_HTML_Help

Also, you can always put the HTML you want under a certain path on the server 
and use mirroring tools. So it's a solved problem.

> Is is searchable and the text is extractable. 

It is not as searchable as HTML or XML is, and the text is not easily 
extractable if there is fancy formatting or layout. And not all FOSS PDF 
viewers have adequate mechanisms for it. 

> Is is
> itself). 

It's much less accessible to the disabled than XHTML is.

> There are RTL issues with PDF though.
> 

Big RTL issues.

Nevertheless, by using DocBook/XML and other tools one can easily generate 
both XHTML and PDF output. And you can convert XHTML to PDF too using the 
print-to-file function of the browsers.

Regards,

	Shlomi Fish

> >> If anyone is willing to contribute, submit an article or give a
> >> feedback, contact Digital Whisper crew here -
> >> [email-masked]
> 
> When I get around to it!
> 

-- 
-----------------------------------------------------------------
Shlomi Fish       http://www.shlomifish.org/
Parody on "The Fountainhead" - http://shlom.in/towtf

---

From: Budilovsky Evgeny <[email-masked]>
Date: Mon, 5 Oct 2009 22:21:19 +0200

Guys,
I think we should take the phrack <http://www.phrack.org/> approach and
publish our issues in plain text. Images can be replaced by ascii-art or in
special cases encoded in base64 and embedded in the text. This will probably
solve the formats wars since no one can argue that simple ascii text is not
supported by it's system.

P.S.
Thanks for the great issue. In case you stick with the pdf format is it
possible to make links click-able from the pdf this will save the copy-paste
from the foxit reader to the firefox.

Best regards,
Evgeny

---

From: Shlomi Fish <[email-masked]>
Date: Tue, 06 Oct 2009 13:54:57 +0200

On Monday 05 Oct 2009 22:21:19 Budilovsky Evgeny wrote:
> special cases encoded in base64 and embedded in the text. This will
>  probably solve the formats wars since no one can argue that simple ascii
>  text is not supported by it's system.

Was that a joke? ASCII Art is very inaccessible too, and usually looks 
horrible. And plaintext is incredibly non-aesthetic. You can easily convert 
XHTML to PDF or plaintext. And if you ask me, even PDF is better than 
plaintext. Plaintext would look incredibly unprofessional, and would indicate
a bad laziness on your part. Let's not go there.

Let's not end up with the copper because we cannot decide between the silver 
and the gold.

Regards,

	Shlomi Fish

> possible to make links click-able from the pdf this will save the
>  copy-paste from the foxit reader to the firefox.
> 
> Best regards,
> Evgeny
> 
> > > > accessibility, inconvenience, low ability to be hacked and re-used,
> > > > and other problems. I don't have a PDF viewer configured in my
> > > > browser, and when clicking on the link, one of them was downloaded to
> > > > my hard-disk, and I am too inconvenienced to open it using a PDF
> > > > viewer.
> > >
> > Nevertheless, by using DocBook/XML and other tools one can easily
> > generate both XHTML and PDF output. And you can convert XHTML to PDF too
> > using the print-to-file function of the browsers.
> >
> > Regards,
> >
> >        Shlomi Fish
> >

-- 
-----------------------------------------------------------------
Shlomi Fish       http://www.shlomifish.org/
Best Introductory Programming Language - http://shlom.in/intro-lang

---

From: Micha Feigin <[email-masked]>
Date: Wed, 7 Oct 2009 00:47:27 +0200

On Sun, 04 Oct 2009 17:47:06 +0200

With PDF you assure format and don't have math and font issues

With a PDF version I can more easily archive the article and print it

You can always use open with instead of save to open the article in a pdf viewer

> above. A PDF version unnecessarily inconveniences me.

Personally for light reading I like html for serious papers pdf is much better.

---

From: Micha Feigin <[email-masked]>
Date: Wed, 7 Oct 2009 00:51:00 +0200

On Mon, 05 Oct 2009 16:25:51 +0200

> print-to-file function of the browsers.

I find that to generally be seriously broken

---

From: Dotan Cohen <[email-masked]>
Date: Fri, 9 Oct 2009 15:11:39 +0200

> and use mirroring tools. So it's a solved problem.

CHM is far from being a universally-available solution. No ebook
reader can read it, and the choices for reading CHM files under Linux
are slim. Furthermore, being HTML-based, there is no reference
implementation for formatting, so it will look different on every
device.

> viewers have adequate mechanisms for it.

So fix your FOSS software. This would need to be done anyway for CHM,
read the previous comment.

> It's much less accessible to the disabled than XHTML is.

Please explain. PDF has disability features built into the document.
You might also want to read up on reflowing PDF documetns for
small-screen devices and screen readers.

>> There are RTL issues with PDF though.

I take that back. There are RTL isues with FOSS PDF readers. Acrobat
on Vista seems to have all the RTL issues taken care of.

> print-to-file function of the browsers.

This is a good point. Does the author want to give multiple options?

-- 
Dotan Cohen

http://what-is-what.com
http://gibberish.co.il