Subject: operating systems book recommendations

From: Muli Ben-Yehuda <[email-masked]>
Date: Thu, 6 May 2004 16:27:06 +0300

Hello, gentle people, 

I'm looking for recommendations on good books for operating systems
implemetntrs. OS theory, OS design and implementation, Linux kernel
anything, CPU architectures, etc. To jump start the discussion, here
are mini-mini reviews of some books I already have or have read: 

- Bovet & Cesati, Understanding the Linux Kernel, both editions, very
good. Strong emphasis on details, not enough on concepts. 
- Linux Device Drivers, Rubini et al, likewise. 
- Linux Kernel Development, Robert Love, Excellent. Clear, readable
and concise. 
- Bach's The Design of the Unix Operating System. 
- Curt Schimme's UNIX Systems for Modern Architectures
- UNIX Internals by Uresh Vahalia

More? 

Cheers, 
Muli 
-- 
Muli Ben-Yehuda
http://www.mulix.org | http://mulix.livejournal.com/

---

From: Eugene Teo <[email-masked]>
Date: Fri, 7 May 2004 07:40:32 +0800

<quote sender="Muli Ben-Yehuda">
> - UNIX Internals by Uresh Vahalia

Remember I showed you my paper? Below, I have references to
two advanced operating system books. You might want to check
out both. Pretty good ones. 

PS: I am in console, and don't have any pdf software atm, 
perhaps you can help me fill in the blanks *g

Eugene

-- 
Eugene TEO   <eugeneteo%eugeneteo!net>   <http://www.anomalistic.org/>
1024D/14A0DDE5 print D851 4574 E357 469C D308  A01E 7321 A38A 14A0 DDE5
main(i) { putchar(182623909 >> (i-1) * 5&31|!!(i<7)<<6) && main(++i); }

---

From: Jason Phillips <[email-masked]>
Date: Thu, 6 May 2004 12:12:02 -0700 (PDT)

I find that any of the O'Reilly books are very informative I'll run down and rattle off some titles for you but O'Reilly Has an extensive library covering just about every topic.

Muli Ben-Yehuda <[email-masked]> wrote:Hello, gentle people, 

More? 

Cheers, 
Muli 

> ATTACHMENT part 2 application/pgp-signature name=signature.asc

---------------------------------
Do you Yahoo!?
Win a $20,000 Career Makeover at Yahoo! HotJobs