Subject: software licenses and hacking

From: Elad Efrat <[email-masked]>
Date: Sat, 26 Mar 2005 20:47:16 +0200

recently i saw something pretty interesting, that
i'd like some responses from people on this list
about - since you are 99% linux/eric s. raymod
zealots. :)

facts:
  - linux, gnu, hamakor preach to use the GPL.
  - eric s. raymond is a linux zealot.
  - eric s. raymond wrote the hacker howto.
  - this is a "hackers" mailing list.

quotes:
  - from the hacker howto:

2. No problem should ever have to be solved twice.
Creative brains are a valuable, limited resource.
They shouldn't be wasted on re-inventing the wheel
when there are so many fascinating new problems
waiting out there.

To behave like a hacker, you have to believe that
the thinking time of other hackers is precious — so
much so that it's almost a moral duty for you to
share information, solve problems and then give
the solutions away just so other hackers can solve
new problems instead of having to perpetually
re-address old ones.

[...]

4. Freedom is good.
Hackers are naturally anti-authoritarian. Anyone
who can give you orders can stop you from solving
whatever problem you're being fascinated by —
and, given the way authoritarian minds work, will
generally find some appallingly stupid reason to do
so. So the authoritarian attitude has to be fought
wherever you find it, lest it smother you and other
hackers.
[...]
Authoritarians thrive on censorship and secrecy.
And they distrust voluntary cooperation and
information-sharing — they only like ‘cooperation'
that they control.

from reading the above, i have to say that i find
the GPL software license to be pretty much anti-
hacking!

looking at the first part (2) we see that the GPL may
force other hackers - who happen to be working
for someone who pays them a paycheck - to solve
the same problem we did again and again, if we
license our code using the GPL; because as we
all remember, not all commercial vendors like
the idea of releasing the source code just yet.

if we insist on using GPL on our software, we're
not giving away our product, thus helping hackers
solve new problems - we may be enforcing them
to focus over and over again solving the same
problems. that attitude is anti-hacker, according
to the hacker-howto by eric s. raymond.

moreover, looking at the seocnd part (4) about
freedom, we see that "anyone who gives you
orders can stop you from solving [...] problem.."
and again this links us directly to the GPL -
which takes away our freedom to decide if we
want to distribute our modificataions to the
code, hence preventing us from solving the
problems *we* care about and making us solve
again and again problems other people might've
solved.

the other paragraph mentions "cooperation they
control" - which is also what the GPL enforces;
effectively, the GPL says "if you want this code,
you have to make your code GPL too." - which
is clearly anti-freedom and anti-hacker.

another resource of information is richard
stallman himself:

http://www.fsf.org/licensing/licenses/why-not-lgpl.html

quoting richard stallman we can clearly see his
anti-hacker attitude, maybe even communism:

"Releasing it under the GPL and limiting its use to
free programs gives our community a real boost. At
least one application program is free software today
specifically because that was necessary for using
Readline."

richard stallman is *proud* of *forcing* someone
to change the license of his code to GPL just
because they wanted to use software he wrote.
this is a crude violation of hackers ethic - he both
took away their freedom to choose license for the
product, and at the same time prevented them
from using a good solution just because he has
a stupid ideology about software licensing!

down further:

"By releasing libraries that are limited to free
software only, we can help each other's free
software packages outdo the proprietary
alternatives. The whole free software movement
will have more popularity, because free software
as a whole will stack up better against the
competition."

richard stallman is not a hacker. richard stallman
cares for one thing only - promoting his ideology
on the expense of other people; who may be
only developers working for a larger company.

by enforcing such limitations, he creates more
work for software developers that only do what
they are asked and paid to do; aswell as
causing a degradation in software quality - an
act which eventually hurts the consumer, who
in most cases couldn't care less about richard
stallman's fight against windmills.

what do people on this list have to say about
this?

-- 
Elad Efrat
PGP Key ID: 0x666EB914

---

From: guy keren <[email-masked]>
Date: Sun, 27 Mar 2005 00:02:29 +0200 (IST)

please don't feed the trolls...

--guy.

On Sat, 26 Mar 2005, Elad Efrat wrote:

> the thinking time of other hackers is precious ? so
> whatever problem you're being fascinated by ?
> information-sharing ? they only like ?cooperation'
> that they control.
>
>
> "By releasing libraries that are limited tofree

-- 
guy

"For world domination - press 1,
 or dial 0, and please hold, for the creator." -- nob o. dy

---

From: Shlomi Fish <[email-masked]>
Date: Sat, 26 Mar 2005 22:02:17 +0200

> about - since you are 99% linux/eric s. raymod

Well, I wouldn't throw such statistics into the air if I were you. 

<<<
New S.E.C. Inquiry: 62.381527% of all statistics made up on the spot.

(taken from http://www.math.temple.edu/~paulos/)

In your case, your statistic fall into the 62.381527%. Some of us may not use 
Linux or encourage its use. And some of us may not agree with everything that 
ESR ever said.

>   - linux, gnu, hamakor preach to use the GPL.

Linux preaches to use the GPL? The Linux Kernel is GPLed, but applications 
that run above it (and many kernel modules) can be non-GPLed. Either they are 
open-source or they are completely proprietary or they are something in 
between. The open-source programs can be GPLed or BSD-style or something in 
between.

GNU naturally advocates the GPL.

Hamakor is about promoting free software in Israel. It takes no side for 
making applications GPLed or against it. As long as an application is free it 
is endorsed by Hamakor.

> new problems instead of having to perpetually

Note "No problem should ever have to be solved _twice_.". If someone writes a 
proprietary program that solves a problem, then someone still needs to write 
an open-source equivalent of it, because the proprietary solution is 
restricted. This is where using the GPL may be preferable.

Also "almost a moral duty for you to share information, solve problems and 
then give the solutions away". How does working on a proprietary program 
falls into that?

> the idea of releasing the source code just yet.

Possibly. But if the software was not GPLed they would make use of it to solve 
a new problem, which would cause the community of open-source hackers to need 
to solve this problem again. Also note that if these hackers are working on 
in-house software, then they are allowed to make use or modify GPLed 
software.

That way, the GPL eventually prevents problems from being solved again and 
again.

> to the hacker-howto by eric s. raymond.

No it's not. If there's a solution for a problem that is GPLed, then as far as 
we as open-source hackers are concerned it is solved and no-one that we care 
about has to solve it again. If someone wants this problem to be solvable in 
a way that will allow building a piece of proprietary software out of it, 
then he lies is beyond our concern. He is not doing something that we 
advocate.

> again and again problems other people might've

But you can solve a problem in an open-source or in-house way using GPLed 
programs. If you want to distribute a proprietary software that does the 
same, that's beyond our concern. You are not properly sharing your solution 
this way.

> is clearly anti-freedom and anti-hacker.

No it's not. First of all, you can link open-source code that is written in a 
GPL-compatible license (e.g: MIT X11, Modified BSD, Clarified Artistic, 
SleepyCat, LGPLed), against a GPLed code with no problems whatsoever. 
Secondly, the purpose of the GPL is to make sure every code that makes use of 
it is free and GPL-compatible. You don't like it, don't use GPLed code.

> anti-hacker attitude, maybe even communism:

"Communism"... didn't we have enough of Microsoft accusing open-source 
activists of being communists?

> because they wanted to use software he wrote.

Otherwise, that software would have been proprietary, which would have been 
much less than ideal. An alternative for them would have been to implement 
the necessary Readline logic on their own. But they decided against it, and 
so released the software under the GPL. They did so willingly. (no one was 
forcing anyone to do anything)

> a stupid ideology about software licensing!

A person has a freedom to choose a license for a program as long as this 
license is compatible with the licenses and distribution terms of the 
software it makes use or is based on. 

> on the expense of other people; 

The free software ideology makes some sense to me. And the more beneficial and 
useful free software there is, the better. The GPL is a tool that can be 
utilized to achieve this, and prevent proprietary software from being 
developed, that otherwise would be free.

> who may be 

Why is GPLed software causing a degradation in software quality? If I 
developed GPLed code and released it, then free software developers can make 
use of it for their projects and so better free software can be developed. It 
can also facilitate making some in-house software. If I did not develop that, 
then the world will not be a better place without it. So it is better to 
develop something under the GPL than not to develop it at all.

In any case, the proprietary software quality won't decrease because of it. It 
might improve, or it might stay the same.

Regards,

	Shlomi Fish

---------------------------------------------------------------------
Shlomi Fish      [email-masked]
Homepage:        http://www.shlomifish.org/

Hacker sees bug. Hacker fixes bug.

---

From: Elad Efrat <[email-masked]>
Date: Sat, 26 Mar 2005 22:10:20 +0200

> please don't feed the trolls...

sure, guy.

http://www.wasabisystems.com/gpl/

read this. or is it trolling too? :)

-- 
Elad Efrat
PGP Key ID: 0x666EB914

---

From: Elad Efrat <[email-masked]>
Date: Sat, 26 Mar 2005 23:38:11 +0200

> Well, I wouldn't throw such statistics into the air if I were you. 

only you can misunderstand the purpose of
such stat...

> making applications GPLed or against it. As long as an application is free it 

hamakor is mirroring 100% GPL'd software.
(here's another made up statistic)

> restricted. This is where using the GPL may be preferable.

by saying this you are enforcing one model
of software development. do you know what
movement emphathized "one" and unity?

> then give the solutions away". How does working on a proprietary program 

it doesn't. but pointing that out you say "if
they act like that, so can we!" instead of
saying "they do that, we do this." very
mature.

> in-house software, then they are allowed to make use or modify GPLed 

let's leave "in-house" software outside
of this discussion; same comment as
above applies.

> That way, the GPL eventually prevents problems from being solved again and 

sure - if you use the GPL license. but
until the entire world uses mostly
open source programs, it's preventing
from problems that reach the desktop
market and possibly other markets
from being solved efficiently.

> then he lies is beyond our concern. He is not doing something that we 

you are again focusing on the open
source movement instead of the quality
of the software and the benefit of the
user. you are not developing software
for a political party, you are developing
software to serve user needs.

the end-user don't *care* what your
motivation is; he is willing to pay - as
we can clearly see - for proven
solutions.

> same, that's beyond our concern. You are not properly sharing your solution 

why is it beyond your concern? because
you care for the ideology behind software
and not its quality; which should alert
anyone who is going to use your software.

people who release their software requesting
only credit truly care for the quality of the
software, where-as people who release
software under the GPL care more for the
ideology and enforcement of a specific
model which is not yet proven to be profitable.

> it is free and GPL-compatible. You don't like it, don't use GPLed code.

again. this is exactly what i'm saying. the
GPL is for people who advocate a cause;
less restrictive licenses are for people who
want to reach a "best of breed" product...

> activists of being communists?

more like, one people, one license, one faith?

> forcing anyone to do anything)

companies have more parameters to take
into account when releasing products than
"making sure its open source and free
software".

if that's what you care about, fine; but dont
call yourself a hacker nor a developer.

> software it makes use or is based on. 

and by writing code that falls under a
license like the GPL that forces other
parts of the program to be GPL aswell,
you're taking away that freedom.

> useful free software there is, the better. The GPL is a tool that can be 

of course. open source is the only way to get
to high quality code; however, it's not the best
way to come up with new ideas nor the best
way to get things done. look at the security
features in solaris 10, for example.

> developed, that otherwise would be free.

why prevent properiaty software from being
developed? it is proven that people will use
what works best for them from all aspects,
or what's costing them the less.

from that point of view, open source software
takes the lead. unfortunately, people who
GPL their code don't see it and blindly follow
richard stallman's faith of "all software must
be free and open source" - which is not true.

> use of it for their projects and so better free software can be developed. It 

large programs today make use of various
libraries and bits of code from many places.
if one project like that is managed by
someone with goals different than yours -
ie., just making high quality software,
regardless of who makes use of it - then she
cant use your GPL'd code.

i refer you to the BSD systems' claims
against the use of GPL'd code, aswell as
the link i posted to wasabi systems.

the world, unfortunately, still is dominated
by microsoft for desktop use. there is a good
chance that open source products are better,
but they are not used. by preventing vendors
from using your code in their products you
only show your fear of them taking it and
making something better of it; forcing them
to (maybe) make their own implementation
which will probably be worse than the open
source alternative.

revolutions dont happen in a day. a good
example for that is firefox - a better product
than internet explorer, that slowly gains its
share of the browser market. what about
its license?

http://www.mozilla.org/MPL/relicensing-faq.html#new-license

"If a piece of code is dual- or triple-licensed,
that means that someone (the licensee) who
modifies and/or distributes it can choose which
of the available sets of license terms they are
operating under."

you want to fork off your own GPL'd
browser? cool. you want to use our code
in your commercial program? that's fine
too; we give you the *freedom* to choose.

why isn't open office getting that much
popularity? it replaces a product that costs
thousands of dollars, it's entirely free, and
provides more or less the same features
the majority of computer users need.

(it may be related to the fact of it using
two non-free licenses, but then again it
may not - this is another interesting
question)

> develop something under the GPL than not to develop it at all.

yes, but it is also better to license something
under an ISC license than the GPL. that way,
you give more people the chance to make a
better product.

> might improve, or it might stay the same.

but its development process might become
slower. properiaty software is not always a
bad thing; sure, it costs a lot of money, but
that does not mean we need to do anything
in our power bring down a market that pays
money to thousands of people.

what is your goal, developing good software
or taking down commercial software vendors?

-- 
Elad Efrat
PGP Key ID: 0x666EB914

---

From: guy keren <[email-masked]>
Date: Sun, 27 Mar 2005 02:57:28 +0200 (IST)

> read this. or is it trolling too? :)

i think you're doing the same mistake many people do - confusing the
free-software movement with the open-source "movement" (quotations added
on purpose).

if you want to take the GPL for what it is - read not what one mister
raymond writes. read what one richard stallman writes.

if you're in for open source only - then you missed the point of the gpl -
and then ofcourse you'll say it's a blasphemy, and BSD should be the one
true license.

so, either you have never read richard stallman's writings, or you are
trolling.

-- 
guy

---

From: Omer Zak <[email-masked]>
Date: Sun, 27 Mar 2005 01:35:22 +0200

On Sat, 2005-03-26 at 20:47 +0200, Elad Efrat wrote:

[... other drivel was snipped ...]

> the GPL software license to be pretty much anti-

I do not know how this logical fallacy is called, but it is similar to
the claim that a democracy is not democratic, because it has laws, which
prohibit people from voting for a political party which aims at
abolishing the democracy a-la Weimar republic's abolition of democracy
by the Nazi party.

Or to the claim that the Israeli Law of Return is racist, because it
discriminates among people of different ancestries - neglecting the fact
that the aim is to have a shelter for a certain people, who are already
discriminated against in other countries.
                                                --- Omer
-- 
Every good master plan involves building a time machine.  Moshe Zadka
My own blog is at http://www.livejournal.com/users/tddpirate/

My opinions, as expressed in this E-mail message, are mine alone.
They do not represent the official policy of any organization with which
I may be affiliated in any way.
WARNING TO SPAMMERS:  at http://www.zak.co.il/spamwarning.html

---

From: Elad Efrat <[email-masked]>
Date: Sun, 27 Mar 2005 07:41:10 +0200

thanks omer for further serving my goal of
showing how non-free the gpl is.

> discriminated against in other countries.

the above mentioned laws are vital for the
survival of democracy; and are the minimal
requirements to assure we have democracy
in a state of jews, serving an entire country
and an entire nation.

the gpl is serving the viewpoint of a single
person, promoting a financial model that
has not been proven profitable regardless
of various claims, tries to prevent people
who don't belong in the "community" from
using its pseudo-free resources (isn't
that a little bit like racism?) and generally
enforces a license on an entire software
just because its base might've been gpl'd.

a bsd license would match your examples,
as it presents only the required minimal
for maintaining credit and protecting from
lawsuits for developers.

good day,
-e.

-- 
Elad Efrat
PGP Key ID: 0x666EB914

---

From: Omer Zak <[email-masked]>
Date: Sun, 27 Mar 2005 09:01:51 +0200

Actually, I have very good personal experience with LGPL, not BSD
license.

I was involved with few projects, in which non-Free software was
developed, and in which a LGPLed library (FriBidi) was used (the same
library in those projects).

The LGPLed library saved us a lot of development time, headaches and
tears.  We found and fixed some bugs in the library and contributed back
the modifications.  The experience felt like being able to hire the
excellent developers of FriBidi to do most of the work for us - but for
free (eventually, we compensated one of the developers, but when it was
financially convenient for us to do so).

                                             --- Omer

-- 
MS-Windows is the Pal-Kal of the PC world.
My own blog is at http://www.livejournal.com/users/tddpirate/

---

From: Shlomi Fish <[email-masked]>
Date: Sun, 27 Mar 2005 10:57:24 +0200

On Sunday 27 March 2005 01:35, Omer Zak wrote:
> Or to the claim that the Israeli Law of Return is racist, 

I beg to differ, but the Israeli Law of Return (and the Law of Citizenship) is 
indeed racist, discriminatory and harmful. It essentially elevates Jews above 
the rest, and gives little way for non-Jews to immigrate to Israel. It 
discriminates between Jews and non-Jews and so by definition is racist. (no 
matter what arguments you can give for it).

I support Israel having a non-discriminatory immigration and citizenship laws. 
The ideal thing would be:

1. Every lawlful person - Jew or non-Jew - will be allowed to immigrate to 
Israel, live there and work there.

2. A person who has lived for a long time in Israel, contributed to society, 
etc. will be entitled to become a citizen.

> because it 

So, "The Possel Be'mumo Possel"? (= "The rejector rejects based on his own 
fault"). Do you want to fight fire with fire? How can you expect people not 
to discriminate when you discriminate yourself. Israel can provide a shelter 
for Jews without being constitutionally racist.

This is getting off-topic here. Interested parties can move this discussion to 
Philosophy-IL:

http://groups.yahoo.com/group/philosophy-il/

Regards,

	Shlomi Fish

---

From: Elad Efrat <[email-masked]>
Date: Sun, 27 Mar 2005 17:07:31 +0200

> financially convenient for us to do so).

THAT's what i'm talking about, THAT"s what richard
stallman DON'T want you to do. LGPL is closer to
BSD than to GPL.

-- 
Elad Efrat
PGP Key ID: 0x666EB914

---

From: Elad Efrat <[email-masked]>
Date: Sun, 27 Mar 2005 17:20:17 +0200

shlomi,

> matter what arguments you can give for it).

i did not spend too much time in class in high-school
nor learned about this subject in any way, so this is
an opinion, but-

israel, or "the land of jews" was funded in 1947/8,
shorly after the end of WW2 and the holocaust out
of a clear need for a state to be a "refugee" to jews
from around the world; where their etnicity will be
part of the state itself and not just a religion in it.

due to the amount of non-jews who lived here at
the time, it was suggested the country will be that
of two nationalities; where both religions will be
respected, etc. this suggestion was rejected by
the arab representitives.

as much as i *dont* connect to jewish religion
or tradition in any way, and in fact detest the
way it is represented today by various parties,
and can not stand enforcement on others'
free will, i understand that if israel becomes a
democratic party that allows immigrants to
come here and become citizens as they like,
we will soon lose the jewish majority, ending
up in an arab state - as there is no chance a
minority of jews will ever succeed in ruling
a country with an arab majority.

this may sound like racism, but it's also
vital for keeping one land for jewish people.
if we inspect the past (holocaust, etc.) and
the current anti-semite actions taken in
various countries, we can clearly realize
that assuring that at least one state for "us"
is required, even at the cost of disallowing
arabs into the wonderful little piece of
ground called israel.

as bad as it may sound, if the arab
population of israel will be requested to
leave they have enough places and
countries to go to; while we don't.

-e.

-- 
Elad Efrat
PGP Key ID: 0x666EB914

---

From: Omer Zak <[email-masked]>
Date: Sun, 27 Mar 2005 17:35:50 +0200 (EET)

> arabs into the wonderful little piece of

Hell has just freezed over!
This time, I agree with Elad the Troll.
My agreement with him is strictly limited to this one issue and is not to
be construed as agreement with him about other issues.

The term which Elad did not use but meant is:
Affirmative Action (translated to Hebrew as "aflaia metakenet").

By the way, I remember an argument from some time ago, in which Elad was
against making Web sites accessible to all browsers - something which
benefits people with disabilities (the usual beneficiaries from
affirmative action regulations).  So it seems that his support for
affirmative action is limited to people with Jewish genes and does not
extend to people with disabilities.
                                             --- Omer
My opinions, as expressed in this E-mail message, are mine alone.
They do not represent the official policy of any organization with which
I may be affiliated in any way.
WARNING TO SPAMMERS:  at http://www.zak.co.il/spamwarning.html

---

From: Elad Efrat <[email-masked]>
Date: Sun, 27 Mar 2005 17:50:09 +0200

> against making Web sites accessible to all browsers - something which

correct. special user needs need be served client-side.
if a website is using standards it's easy for a browser to
parse it and process the input as the person using the
special browser needs - narrate it, enlarge fonts, or
whatever.

> extend to people with disabilities.

jewish genes is something that hitler would say. i
suggest you think twice before posting something
like that.

-e.

-- 
Elad Efrat
PGP Key ID: 0x666EB914

---

From: Muli Ben-Yehuda <[email-masked]>
Date: Sun, 27 Mar 2005 21:34:50 +0200

> suggest you think twice before posting something

I invoke Godwin's law; you've just lost this argument. Thank you
for playing!

Cheers,
Muli
-- 
Muli Ben-Yehuda
http://www.mulix.org | http://mulix.livejournal.com/