Subject: the future of dynamic languages

From: Gabor Szabo <[email-masked]>
Date: Mon, 20 Dec 2004 12:31:46 +0200 (IST)

With all the discussion lately about Java I'd appreciate to
read your opinion about the place and future of dynamic
languages such as Python, Ruby, Perl5-6, Tcl, PHP, etc.

Here is a white paper from ActiveState regarding the issue:
http://www.activestate.com/Company/NewsRoom/whitepapers.plex

    Gabor

---

From: omer mussaev <[email-masked]>
Date: Mon, 20 Dec 2004 04:01:48 -0800 (PST)

> languages such as Python, Ruby, Perl5-6, Tcl, PHP,

In my opinion dynamic languages do have a place in the
future. 

Large applications had always included some support
for scripting languages. I had worked with an
application that was scriptable in perl-workalike,
another that was scriptable in Prolog; we had
implemented a system that was scriptable in Java (we
compiled it into bytecodes on the fly, getting great
performance and ultimate flexiblity). I have enjoyed
lately a computer game that was scripted in Lua.

Lately, however, there are at least 2 novel trends
that seem to make the dynamic languages even more
relevant:
  - "Mobile code" [0]
    Mobile code must run in security cages, requesting
    its own environment on the fly. 
    Dynamic language suit such model nicely.

  - Leveraging the open-source/3rd party components.
    Provided that one can set up quite a large system
    out of 3rd party components (some of which may be
    open-source), a need for good "glue language" is
    very strong.

I did not like this paper.
The paper tries to sell a viewpoint of "dynamic
language must be open-source". I do not see any
technical reasons for a language to be open-source to
be dynamic. 

In my school a dynamics of a language is property of a
runtime system, not of syntax or of a community. 

>     Gabor

[0] Mobile code is a trendy name for code that is 
    downloaded before being executed. 

=====
--
o.m.

__________________________________ 
Do you Yahoo!? 
Read only the mail you want - Yahoo! Mail SpamGuard. 
http://promotions.yahoo.com/new_mail

---

From: Tzafrir Cohen <[email-masked]>
Date: Sat, 25 Dec 2004 08:23:59 +0200

> http://www.activestate.com/Company/NewsRoom/whitepapers.plex

I don't know TCL much, but it has gained a reputation of a bit more
glorified macro-processing and less a "real" dynamic language. Any
comments on that?

-- 
Tzafrir Cohen                       +---------------------------+
http://www.technion.ac.il/~tzafrir/ |vim is a mutt's best friend|
mailto:[email-masked]       +---------------------------+