Subject: Daniel

From: "Evgeny Gesin" <[email-masked]>
Date: Mon, 01 Nov 2004 14:28:21 -0000

I'm *urgently* looking for a J2EE expert for one of my clients in
Herzliya to immideately apply this job

---

From: Omer Zak <[email-masked]>
Date: Mon, 1 Nov 2004 17:00:18 +0200 (EET)

I accept job postings on Linux-IL as appropriate, because companies do
need Linux experts once in a while.

But Hackers-IL is too general group for job postings, which ask for a
specific skill.  Appropriate job postings here would be for jobs, which
require hacker-level skills (such as mastery of several programming
language, ability to disassemble machine language code, solve expecially
tough problems, etc.).

I would advise Evgeny Gesin to post his job posting to a J2EE specific
mailing list.

> Herzliya to immideately apply this job
                                             --- Omer
My opinions, as expressed in this E-mail message, are mine alone.
They do not represent the official policy of any organization with which
I may be affiliated in any way.
WARNING TO SPAMMERS:  at http://www.zak.co.il/spamwarning.html

---

From: "Evgeny Gesin" <[email-masked]>
Date: Mon, 01 Nov 2004 15:08:10 -0000

Thanks for clarification and sorry.
I stay here for months, but don't understand what is this club for. :)

Evgeny Gesin
Javadesk / AllTelescopes

---

From: Ori Idan <[email-masked]>
Date: Mon, 01 Nov 2004 17:13:14 +0200

>On Mon, 1 Nov 2004, Evgeny Gesin wrote:
A good explenation of what is J2EE and it's relationship to Java will be 
appropriate here I think.

I think that too much meta discussions on what should be and should not 
be on this list are also not appropriate.

We should refer anyone to a FAQ on the wiki.

--

Ori Idan

---

From: "Evgeny Gesin" <[email-masked]>
Date: Mon, 01 Nov 2004 16:33:22 -0000

> A good explenation of what is J2EE and it's relationship
> to Java will be appropriate here I think.

Basically Java is made up of:

J2SE - Java Standard Edition (standard APIs + GUI)

J2EE - Java Enterprise Edition (APIs to work with Enterprise backends,
such as databases, emails, etc)

J2ME - Java Micro Edition (APIs to program mobile devices, such phone,
PDAs, etc)

What about astronomy? Is anyone interested? :)

Evgeny Gesin
Javadesk / AllTelescopes

---

From: Omer Zak <[email-masked]>
Date: Mon, 1 Nov 2004 19:21:59 +0200 (EET)

> I stay here for months, but don't understand what is this club for. :)

About this point you are totally right.
It is very difficult to know what a club (or mailing list) is for when it
is quiet for long time.

Typical subjects for Hackers-IL:
- Managing projects with 10^7 LOC
- Lambda calculus
- Computations with transfinite numbers
- DMCA and similar laws in other countries
- Copyright issues not specific to Linux
- Reverse engineering of proprietary file formats
- Philosophical discussions, which have connection (even if tenous) to
  software and computers.
- Nanotechnology
- Interesting hacks
etc.
etc.

DISCLAIMER:  the above is my personal opinion.  Other participants may
disagree with me.
                                             --- Omer

NOTE:  the question of existence of the IGLU Cabal is not on-topic
anymore, as it was already discussed from all possible angles in Signature
lines of few regular Hackers-IL participants.  This is besides the fact
that the IGLU Cabal Does Not Exist, and Hamakor officially denies any
relationship with the IGLU Cabal.

---

From: guy keren <[email-masked]>
Date: Mon, 1 Nov 2004 21:25:07 +0200 (IST)

> J2SE - Java Standard Edition (standard APIs + GUI)

that's not all. there's a large run-time library that goes with this, with
things related to "general purpose" programming - such as strings
manipulation, data collections, multi-threading primitives, properties
handling, etc, etc, etc. unlike C++, java is the OS, so it has to supply
all the things that are normally supplied by the operating system and its
code libraries.

> such as databases, emails, etc)

and the EJB thingi ("enterprise java beans" - not that i am aware of
non-enterprise java beans...).

one can go to sun's java web site, and see the APIs available for J2SE and
the APIs available for J2EE (which is a super-set of J2SE, btw). this is
all very annoying when you're developing with J2EE (which is, frankly,
what everyone does unless they work with J2ME, or write java applets,
perhaps).

now comes questions such as:

1. is RMI part of J2SE or J2EE?

2. is the CORBA intergratoin part of J2SE or J2EE?

etc.

> What about astronomy? Is anyone interested? :)

if it's about how to hack a small telescope in order to see the moons of
jupiter, then just shoot.

are we having fun yet?

-- 
guy

"For world domination - press 1,
 or dial 0, and please hold, for the creator." -- nob o. dy

---

From: "Evgeny Gesin" <[email-masked]>
Date: Mon, 01 Nov 2004 19:23:14 -0000

> ...bla-bla-bla...

You know a lot!

> are we having fun yet?

We? You! :)

Evgeny Gesin
Javadesk / AllTelescopes

---

From: omer mussaev <[email-masked]>
Date: Mon, 1 Nov 2004 11:26:07 -0800 (PST)

> > such as databases, emails, etc)

J2EE takes the notion of OS further. No J2EE app 
lives by itself, but rather is deployed in some kind
of "application server/container". The "server" 
provides all novel features, such as load balancing,
"hot-deploying", logging, transactions, centralized
configuration, falut-tolerance, ease of use and 
web framework. The app itself uses all that features 
as a black box and contains business logic only.

This kind of technology should appeal to anyone who's
determined to make one with a lots of data to swallow
pay a lot for ability to swallow that data fast.

> non-enterprise java beans...).

Non-enterprise java beans are part of past.
These were the first attempts to create 
component-based computing. It started with 
the observation that once a component is created,
it can be self describing as long as it adhers to 
certain interface. Actually, this is quite correct as 
well for certainly non-Java technologies - such as
ELF.

These beans were used for self-contained UI widgets.
These beans are remembered now in Java by "bean 
syntax" which forces one to manipulate attributes by
setter methods with standartized names -
setFoo(newFoo)
and getFoo(). 

It's quite amazing to actually meet application that 
was written before all that standartization took place

- amazing for pretty painful value of amazing.

> 1. is RMI part of J2SE or J2EE?

J2SE.

> 2. is the CORBA intergratoin part of J2SE or J2EE?

Ditto.

> etc.

A rule of thumb is if you can not pronounce the name
of a technology, it's J2EE. JMX and JMS are noteworty
exception.
> jupiter, then just shoot.

Kinda.

I would like still to discuss the dissassembly output 
for PowerPC, if you don't mind....

=====
--
o.m.

__________________________________
Do you Yahoo!?
Y! Messenger - Communicate in real time. Download now. 
http://messenger.yahoo.com

---

From: Tal Rotbart <[email-masked]>
Date: Mon, 1 Nov 2004 23:46:00 +0200

Hey Omer,

Pretty thorough list, but you forgot:

More typical subjects for Hackers-IL:
- Shlomi Fish
- Metadiscussions about Shlomi Fish
- Discussions about what is off-topic or not
- Meta-discussions about whehter discussion about what is off-topic or
not, is off-topic or not.
- List of typical subjects for Hackers-IL
- Literal ways to make any discussion infinitely recursive

JM2C,
Tal

On Mon, 1 Nov 2004 19:21:59 +0200 (EET), Omer Zak <[email-masked]> wrote:
> Yahoo! Groups Links

-- 
/************************************************

  Tal 'redbeard' Rotbart
  Software Wizard

  eMail:  redbeard of gmail dot com
  Tel:    +972-2-671-6178
  Mobile: +972-52-896-5025

  Snail mail:
          Klozner 7/2
          Jerusalem 93388
          ISRAEL

************************************************/

---

From: Oleg Goldshmidt <[email-masked]>
Date: 01 Nov 2004 23:54:59 +0000

omer mussaev <[email-masked]> writes:

> J2EE takes the notion of OS further. No J2EE app lives by itself,
> but rather is deployed in some kind of "application
> server/container". The "server" provides all novel features, such as
> load balancing, "hot-deploying", logging, transactions, centralized
> configuration, falut-tolerance, ease of use and web framework. The
> app itself uses all that features as a black box and contains
> business logic only.

Pardon my ignorance, but as long as we are having this (more on-topic
than most) discussion, is all of the above a part of J2EE (i.e. Java
the language) or a part of an "application server" or "middleware" or
whatchamacallit, such as Websphere or Weblogic or Tomcat etc? I
realize that the watchamacallit may be intended to run J2EE and may be
written (completely or in part) in Java, but I would still like to
understand what the case is.

-- 
Oleg Goldshmidt | [email-masked]

---

From: Tal Rotbart <[email-masked]>
Date: Tue, 2 Nov 2004 06:59:35 +0200

Websphere, JBoss, etc. are J2EE containers -- that is they aspire to
be a standards-complying (yeah right) implementations of the J2EE
specifications designed to deploy and run Enterprise Java Beans and
web-applications (Servlets/JSP based).

So they are both application servers, middleware and a whatchamacallit :)

-Tal

  Tal 'redbeard' Rotbart
  Software Wizard

  Snail mail:
          Klozner 7/2
          Jerusalem 93388
          ISRAEL

---

From: omer mussaev <[email-masked]>
Date: Tue, 2 Nov 2004 00:28:27 -0800 (PST)

J2EE is not "Java the language", but rather set of 
technologies, standards, conventions, formats and 
patterns aimed at "enterprise data processing", 
designed and implemented by Sun and using Java.

Thus definition of "applicaiton container" is 
definitely part of J2EE - but not of "Java the 
language".

--- Tal Rotbart <[email-masked]> wrote:

> lives by itself,
> web framework. The

=====
--
o.m.

__________________________________ 
Do you Yahoo!? 
Check out the new Yahoo! Front Page. 
www.yahoo.com