Subject: Recommendation for Indentation in kernel code.

From: Tzahi Fadida <[email-masked]>
Date: Fri, 1 Jun 2007 17:10:30 +0300

Hi,
I am researching coding styles for kernel code and enforcement tools.
I think i like the benefits of BSD/KNF coding style:
see http://en.wikipedia.org/wiki/Indent_style

(Specifically the 8 spaces for blocks and 4 for function breaks are nice).

However, liking and practical are two different things.
I need a script/s that:
1) Indent and conform to the coding style.
2) Can say that a code is non-conformant by showing the offending line
(this is important so people will not commit non-conformant files to version 
control systems).
3) Must work both on Unix/Linux systems as well as 
(and this is important for a cross platform program/ers) Windows.
If it is not cross-platform no one will even consider using it.

-- 
Regards,
        Tzahi.
--
Tzahi Fadida
Blog: http://tzahi.blogsite.org | Home Site: http://tzahi.webhop.info
WARNING TO SPAMMERS:  see at 
http://members.lycos.co.uk/my2nis/spamwarning.html

---

From: guy keren <[email-masked]>
Date: Sat, 02 Jun 2007 13:27:43 +0300

> see http://en.wikipedia.org/wiki/Indent_style

when you write code for the linux kernel - use the linux kernel coding 
conventions.

when you write code for the (net/free/open)bsd kernel - use the specific 
bsd kernel's coding conventions.

for windows - i guess they have their own conventions.

--guy

---

From: Tzahi Fadida <[email-masked]>
Date: Fri, 8 Jun 2007 18:13:16 +0300

From your experience,
do you know of a cross-platform tool that can be used for the code 
beutification?
Even proprietary, we are willing to invest.
When i tried INDENT on windows, i found that i don't know how to take out
all the typenames as can be done in linux. I am looking for a program that can 
also do that. From what i understand they take it out from the binary symbols 
because types are not necessarily declared in your own code.