Subject: Help with Defining Syntax

From: "Tzahi Fadida" <[email-masked]>
Date: Wed, 2 Feb 2005 03:26:07 +0200

Hi all,
I am trying to define syntax for an sql operator I am researching.
Since its research I need to formally define it.
the operator currently looks like FD(R1,...,RN)
in the FROM line. like: select * from A,FD(R1,...,RN).
If someone can point me to formal ways to define
it I will appreciate it.

Alternatively, I was also thinking about doing something much more
complex but it really depends on how complex it would
be to define it since its not my main research.
Something like:
FD A,B,C USING (A.*,B.[a,b,c]?,operator) OR (A.+,B.[a,b,c],opset.?) ...

with ?,*,+ with the same meaning as in xml.

It should translate to something similar to a CNF statement with
exception of
the operator not being an OR or AND but their result is
boolean (signifying different degrees of equality).

Regards,
	tzahi.

* - * - *
Itzhak Fadida
MSc Student
Information System Engineering Area
Faculty of Industrial Engineering & Management
Technion - Israel Institute of Technology
Technion City, Haifa, Israel 32000
Technion Email: [email-masked]
Alternative Email: [email-masked]
Office Phone(from Israel): 04-8292226
Office Location: Technion, Cooper Bldg. room 427.
* - * - * - * - * - * - * - * - * - * - * - * - * - * - *

WARNING TO SPAMMERS:  see at
http://members.lycos.co.uk/my2nis/spamwarning.html

---

From: Arik Baratz <[email-masked]>
Date: Thu, 3 Feb 2005 18:53:49 +0200

> If someone can point me to formal ways to define

Sorry, I can't make heads and tails from your request.

Do you mean something of the sort:

op ::= 'FD' '(' args ')'
args ::= arg | arg , args
arg ::= 

and so on?

-- Arik

---

From: "Tzahi Fadida" <[email-masked]>
Date: Thu, 3 Feb 2005 21:36:23 +0200

I don't know either, this is my question. how do you formally define a
syntax. specifically how they define sql syntax.

with algol 60 they used BNF and later EBNF for others.
I don't know how they formally defined sql and functions in it.

> -----Original Message-----
> From: Arik Baratz [mailto:[email-masked]] 
> Sent: Thursday, February 03, 2005 6:54 PM
> To: [email-masked]
> Subject: Re: [hackers-il] Help with Defining Syntax
> 
> 
> 
> > Since its research I need to formally define it. the operator 
> > currently looks like FD(R1,...,RN) in the FROM line. like: select * 
> > from A,FD(R1,...,RN). If someone can point me to formal 
> ways to define
> > it I will appreciate it.
> 
> Yahoo! Groups Links