Subject: New Article: "What Makes Software High-Quality?"

From: Shlomi Fish <[email-masked]>
Date: Tue, 6 May 2008 12:12:31 +0300

Hi all!

Here's a new article, fresh off the electronic press:

http://www.shlomifish.org/philosophy/computers/high-quality-software/

It's available as HTML to read online, PDF (but please don't print it) and 
DocBook/XML. The Licence is CC-by-2.5 (or later).

Comments, suggestions, corrections, rants and raves are welcome.

Regards,

	Shlomi Fish

-----------------------------------------------------------------
Shlomi Fish       http://www.shlomifish.org/
Rethinking CPAN - http://xrl.us/bjn7p

The bad thing about hardware is that it sometimes work and sometimes doesn't.
The good thing about software is that it's consistent: it always does not
work, and it always does not work in exactly the same way.

---

From: Omer Zak <[email-masked]>
Date: Tue, 06 May 2008 12:48:29 +0300

On Tue, 2008-05-06 at 12:47 +0300, Shachar Shemesh wrote:
> Shlomi Fish wrote:
> If it's CC-by-2.5, then why not print it?

To save some precious natural CO2 disposal units?
Because the article is still in flux and you had better wait 3 months
until it stabilizes before printing it on parchment?

                                         --- Omer

-- 
"Kosher" Cellphones (cellphones with blocked SMS, video and Internet)
are menace to the deaf.  They must be outlawed!
(See also: http://www.zak.co.il/tddpirate/2006/04/21/the-grave-danger-to-the-deaf-from-kosher-cellphones/)
My own blog is at http://www.zak.co.il/tddpirate/

My opinions, as expressed in this E-mail message, are mine alone.
They do not represent the official policy of any organization with which
I may be affiliated in any way.
WARNING TO SPAMMERS:  at http://www.zak.co.il/spamwarning.html

---

From: Shlomi Fish <[email-masked]>
Date: Tue, 6 May 2008 13:05:00 +0300

Hi!

On Tuesday 06 May 2008, Shachar Shemesh wrote:
> > It's available as HTML to read online, PDF (but please don't print it)
> > and DocBook/XML. The Licence is CC-by-2.5 (or later).
>

You are allowed to print it, of course. It's legal, and I approve it. But I 
still find it wasteful, because it's a waste of paper and (due to the 
restrictions on Hemp production) causes de-forestation.

So, please think twice before you do.

Regards,

	Shlomi Fish

-----------------------------------------------------------------
Shlomi Fish       http://www.shlomifish.org/
Best Introductory Programming Language - http://xrl.us/bjn84