Subject: Impact of "trusted computing" on Free Software?

From: Omer Zak <[email-masked]>
Date: Wed, 16 Mar 2005 22:53:40 +0200

http://news.com.com/2100-7355_3-5619035.html?type=pt&part=inv&tag=feed&subj=news
"Hardware security sneaks into PCs".
This time, Microsoft is late with the relevant OS support, so hardware
makers are free to implement their "trusted computing" schemes, and
Microsoft will have to follow suit.

My question/concern is:  will it be possible to use Free Software on
such hardware, and if yes - under what conditions?

What alternatives are there for companies, which want to keep their
sensitive applications and data secret and/or tamper proof?

How long will it take before someone develops a computer virus, which
circumvents the "trusted computing" protections?
                                            --- Omer
-- 
Delay is the deadliest form of denial.    C. Northcote Parkinson
My own blog is at http://www.livejournal.com/users/tddpirate/

My opinions, as expressed in this E-mail message, are mine alone.
They do not represent the official policy of any organization with which
I may be affiliated in any way.
WARNING TO SPAMMERS:  at http://www.zak.co.il/spamwarning.html

---

From: Elad Efrat <[email-masked]>
Date: Fri, 18 Mar 2005 19:43:40 +0200

> such hardware, and if yes - under what conditions?

as with any software, if specifications exist, the
drivers can be written. :) OS projects that want
to ask the hardware vendors to release the
specifications, unless they already did so..

as for the conditions - this is largely related to
the license under which the specifications
will be released.

if the latter would be released under an NDA,
you could probably see support for it only in
linux where features are always inserted even
if you have to sell your soul to the devil to get
the specs for implementing them :)

if released to the general public, however,
under a non-restrictive license, you could
probably see most (all?) open source OS
projects add support.

> sensitive applications and data secret and/or tamper proof?

pgp? cgd? gdbe? basically, free software
is still software...

> circumvents the "trusted computing" protections?

i wouldn't call such a development a virus;
i think an exploit would be more appropriate,
as you would have to find some weakness in
the implementation that allowed you to
somewhat bypass it.

more on the subject - remember the cpu id
intel wanted to get in at some point and was
rejected? this is, as it seems, another attempt
at storing unique data on a non-volatile part
of the hardware while having it also accessible
via software.. i think that this opens the door
to fingerprinting computers, and possibly
invading your privacy.

-e.

-- 
Elad Efrat
PGP Key ID: 0x666EB914

---

From: Arik Baratz <[email-masked]>
Date: Fri, 18 Mar 2005 20:00:27 +0200

> specifications, unless they already did so..

Hi all

Well, this really depends. What if the APIs are open, the specs are
free etc. etc. BUT you have to get a signature on your code from
micro^H^H^H^H^H a trusted party so the hardware chip can verify it.

Did I misunderstand the technology, or is this how it's going to work?

-- Arik