Subject: RE: [hackers-il] Finished [was Re: Ongoing translation of "Joel on Software" "Rub aDub Dub"]

From: "Arik Baratz" <[email-masked]>
Date: Sun, 19 Oct 2003 16:56:56 +0200

-----Original Message-----
From: Shlomi Fish [mailto:[email-masked]]
Subject: [hackers-il] Finished [was Re: Ongoing translation of "Joel on Software" "Rub aDub Dub"]

> OK, I finished translating the document. You can find it here:
>
> http://t2.technion.ac.il/~shlomif/rub-a-dub/
> 
> Now, I need one or more people to go over the translation and copy edit
> it.

I'm sorry to say, Shlomi, but an automated translation would have done much better.

Like I've said last time you embarked on such a mission, you cannot translate "There were too many things in the code that made it A PAIN to run anywhere else" to "...SheGarmu Lo LeHiot Ke'ev LeHaritz...".

Listen: You cannot translate idioms literally. You just can't. If you go to a non-English speaker, Hebrew native, and tell him "Linsoa Ad Kan Haya Li Ke'ev" they will look at you funny, and will not understand. An English speaker will just frown and tell you that that idiom does not translate well, and it doesn't sound good in Hebrew.

My suggestion to you is go over your translation, and pretend you DON'T know English, and see which parts just come out at you as illegible or strange. Then rewrite.

And no I can't actually take the time and translate it myself.

-- Arik

---

From: Gilad Ben-Yossef <[email-masked]>
Date: Sun, 19 Oct 2003 17:14:57 +0200

On Sunday 19 October 2003 16:56, Arik Baratz wrote:

> Listen: You cannot translate idioms literally. You just can't. If you go to
> a non-English speaker, Hebrew native, and tell him "Linsoa Ad Kan Haya Li
> Ke'ev" they will look at you funny, and will not understand. An English
> speaker will just frown and tell you that that idiom does not translate
> well, and it doesn't sound good in Hebrew.
>

A native English speaking friend of mind gets a real kick out of using the 
phrase: "And the cuecumbers shall rise and smithe the gardner" in otherwise 
mundane communication with Americans. He reports some of them have actually 
grown to like this important idiom and started using it themselves... folks, 
this might be a new meme.

This guy however always wears black and reads email with Pine on an Indy box, 
so he is excentric in other ways too :-)

Gilad

-- 
Gilad Ben-Yossef <[email-masked]>
Codefidence. A name you can trust (tm)
http://www.codefidence.com

---

From: Shlomi Fish <[email-masked]>
Date: Sun, 19 Oct 2003 21:12:35 +0200 (IST)

Aarrggh! Mailer does not cut long lines. Have to reformat.

On Sun, 19 Oct 2003, Arik Baratz wrote:

> Like I've said last time you embarked on such a mission, you cannot
> translate "There were too many things in the code that made it A PAIN to
> run anywhere else" to "...SheGarmu Lo LeHiot Ke'ev LeHaritz...".
>

I know that did not sound too right the when I translated it, but could
not thing of the equivalent Hebrew idiom. (any suggestsions, anyone)?

You are right in this respect, of course.

> My suggestion to you is go over your translation, and pretend you DON'T know
> English, and see which parts just come out at you as illegible or
> strange. Then rewrite.
>

> And no I can't actually take the time and translate it myself.

I'm not asking you to translate it. I'm asking you (or whoever takes the
position) to go over the translation and correct it where he sees
appropriate.

Regards,

	Shlomi Fish

> -- Arik
>
>
>
> To unsubscribe from this group, send an email to:
> [email-masked]
>
>
>
> Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
>
>

----------------------------------------------------------------------
Shlomi Fish        [email-masked]
Home Page:         http://t2.technion.ac.il/~shlomif/

An apple a day will keep a doctor away. Two apples a day will keep two
doctors away.

	Falk Fish

---

From: Shoshannah Forbes <[email-masked]>
Date: Tue, 21 Oct 2003 09:51:40 +0200

> not thing of the equivalent Hebrew idiom. (any suggestsions, anyone)?

I haven't had a chance yet to read and compare to the original, but a 
general rule of thumb would be that if there is no equivalent Hebrew 
idiom, then drop the idiom completely, and translate "plain".

Depending on the משלב (mishlav) of the Hebrew, something which is "a 
pain" in English can usually be translated well as
"מעצבן" "טירחה" or "נידנוד"
(for the people with Hebrew challenged email: the words above are 
"Me'atzben", "Tir'cha" and "nid'nud")

ֱֳ

---

From: Shlomi Fish <[email-masked]>
Date: Tue, 21 Oct 2003 18:46:16 +0200 (IST)

> "Me'atzben", "Tir'cha" and "nid'nud")

The context is:

<<<
Various friends asked me if they could use FogBUGZ at their companies. The
trouble was, it had too many hardcoded things that made it a pain to run
anywhere other than on the original computer where it was deployed. I had
used a bunch of SQL Server stored procedures, which meant that you needed
SQL Server to run FogBUGZ, which was expensive and overkill for some of
the two person teams that wanted to run it. And so on.

I temporarily translated it as "Kashe". Maybe "Tirha" is better here.

Regards,

	Shlomi Fish

	Falk Fish