Subject: Importance of support for non-MSIE browsers

From: Omer Zak <[email-masked]>
Date: Thu, 17 Feb 2005 21:18:29 +0200

http://www.shlomifish.org/lecture/LAMP/slides/compatibility/non-msie.html lists several reasons why non-MSIE browsers should be supported.
One important reason was left out:  ACCESSIBILITY!

Blind people use text-based browsers (such as lynx).

People with motor disabilities sometimes need special I/O devices for
interacting with their computer, so they may need special browsers,
which follow different man-machine interaction paradigms.
                                                       --- Omer
-- 
My own blog is at http://www.livejournal.com/users/tddpirate/

My opinions, as expressed in this E-mail message, are mine alone.
They do not represent the official policy of any organization with which
I may be affiliated in any way.
WARNING TO SPAMMERS:  at http://www.zak.co.il/spamwarning.html

---

From: "Tzahi Fadida" <[email-masked]>
Date: Thu, 17 Feb 2005 21:59:01 +0200

I am not saying you shouldn't support non-msie browsers but your
logic is faulty here.
check out VLC TTS browser which is MSIE based.
http://www.edict.com.hk/texttospeech/
so accessibility is not really a problem when using msie.

Regards,
	tzahi.

> -----Original Message-----
> From: Omer Zak [mailto:[email-masked]] 
> Sent: Thursday, February 17, 2005 9:18 PM
> To: hackers-il
> Subject: [hackers-il] Importance of support for non-MSIE browsers
> 
> 
> 
> http://www.shlomifish.org/lecture/LAMP/slides/compatibility/no
> n-msie.html lists several reasons why non-MSIE browsers 
> should be supported. One important reason was left out:  
> ACCESSIBILITY!
> 
> People with motor disabilities sometimes need special I/O 
> devices for interacting with their computer, so they may need 
> special browsers, which follow different man-machine 
> interaction paradigms.
>                                                        --- Omer
> -- 
> My opinions, as expressed in this E-mail message, are mine 
> alone. They do not represent the official policy of any 
> organization with which I may be affiliated in any way. 
> Yahoo! Groups Links

---

From: Omer Zak <[email-masked]>
Date: Thu, 17 Feb 2005 22:08:42 +0200

> so accessibility is not really a problem when using msie.

OK, English-speaking surfers are taken take care of.

But!
What about Web sites, which use languages, for which there is no good
text-to-speech engine [1][2]?
                                                --- Omer
[1] According to Ori Idan in the Haifux Linux Accessibility lecture held
few months ago, the existing Hebrew text-to-speech implementations
suffer from unsatisfactory quality of speech.
[2] If you have high-quality Hebrew text-to-speech implementation, then
Bezeq are desperately looking for you.  See RFI No. 45/05/007/0, whose
advertisement appeared in Yediot Aharonot three days ago.

-- 
Bluetooth: new device found: Airbus A310

---

From: Elad Efrat <[email-masked]>
Date: Thu, 17 Feb 2005 22:28:02 +0200

>text-to-speech engine [1][2]?
i'm afraid you're taking things too far. a web developer can't
make sure that every browser for every kind of person who
has any kind of problem is supported. this is time consuming
and not worth the trouble.

the standard is how IE renders websites. start flexing or
start mailing microsoft to make a change. ignoring IE by
not using it is probably the dumbest solution to this
problem anyone could've come up with.