Subject: RE: [hackers-il] We had computer viruses. Now tumors?

From: Chen Shapira <[email-masked]>
Date: Mon, 25 Mar 2002 19:26:10 +0200

> Even a sleep process takes up resources, such as memory.
> On modern systems with shared libraries and bloated programs, 
> even "simple"
> programs tend to take up a lot of memory. Do "sleep 1000&" 
> and then do a
> cat /proc/<process-number>/status. On my system I see:
> 	VmSize:     1868 kB
> 	VmLck:         0 kB
> 	VmRSS:       620 kB
> 	VmData:       64 kB
> 	VmStk:        20 kB
> 	VmExe:        12 kB
> 	VmLib:      1528 kB
> I'm not sure what that means exactly, and which parts of that 
> are shared
> between different sleeps, but probably at least some of it is 
> not shared.

OK, I think I know why I got confused:

1. I confused processes with threads (yeah, typical for windows programmers)

2. "Sleeping proccess takes almost 0 resources" I guess this statement was
supposed to differentiate between sleep and a loop

3. someone once told me that in windows the number of running processes is
limited (true), while in linux, it isn't. I guess I should have checked that

Thanks for patiently tolarating a Linux 101 course.

Chen.

---

From: Oleg Goldshmidt <[email-masked]>
Date: 26 Mar 2002 09:47:55 +0200

> limited (true), while in linux, it isn't. I guess I should have checked that

Assuming no knowledge of anything [sic! :-)] and not checking anything
at all: not limiting a resource - any resource whatsoever - seems to
me a recipe for a security hole / abuse. And we pride linux on being
more secure than any quick'n'dirty OS, don't we?

Nice hack, Nadav.

-- 
Oleg Goldshmidt | [email-masked] 
[Lisp] is the only computer language that is beautiful. 
                      - Neal Stephenson