Subject: Is advocacy relevant to design in general and good design in part icular?

From: Omer Musaev <[email-masked]>
Date: Thu, 7 Nov 2002 15:14:56 +0200

' -----Original Message-----
' From: Shlomi Fish [mailto:[email-masked]]

[ details on BitKeeper license and Shlomi's point of view skipped, 
  due to lack of my interest in software configuration. Nothing personal ]

' Other than that, I think advocacy articles are a perfectly fine way of
' advancing the community. The most productive things in a 
' worker's life are
' the key decisions he make that change the way he ran things before.
' Actualy coding is much less productive. Writing a lot of code that
' eventually turns out that could have been much better designed is much
' less productive than coming with a good design and implementing the
' modified code. Now, the good design is a key decision.

While appropriate design is one of more influencing steps in project
lifetime, I do not see the relationship between advocacy articles and 
design, let alone good design. Can you ellaborate on that relationship?

' 
' Regards,
' 
' 	Shlomi Fish

---

From: Shlomi Fish <[email-masked]>
Date: Thu, 7 Nov 2002 21:56:47 +0200 (IST)

On Thu, 7 Nov 2002, Omer Musaev wrote:

> While appropriatedesign is one of more influencing steps in project

Maybe I mixed two different but related thoughts I had. I know some of the
design decisions I made for Freeceell Solver and other projects were
influenced by what I read in Joel on Software, The Cathedral and the
Bazaar and other sources. Maybe I'm not a very intuitive programmer if I
was influenced by that. But wisdom is good whether one was "born" with it,
gained it by experience, or read it somewhere.

Just my 20 agoroth,

	Shlomi Fish

> '
> ' Regards,
> '
> ' 	Shlomi Fish
>
>
> To unsubscribe from this group, send an email to:
> [email-masked]
>
>
>
> Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
>
>

----------------------------------------------------------------------
Shlomi Fish        [email-masked]
Home Page:         http://t2.technion.ac.il/~shlomif/
Home E-mail:       [email-masked]

"Let's suppose you have a table with 2^n cups..."
"Wait a second - is n a natural number?"