Subject: RE: [hackers-il] Re: An Analysis of the Joel Test in regards to O S [was Re: Rules for Open Source development (the serious version)]

From: Omer Musaev <[email-masked]>
Date: Wed, 23 Jan 2002 18:55:47 +0200

> -----Original Message-----
> From: Adi Stav [mailto:[email-masked]]
> Sent: Wednesday, January 23, 2002 7:43 PM
> To: [email-masked]
> Subject: Re: [hackers-il] Re: An Analysis of the Joel Test in 
> regards to
> OS [was Re: Rules for Open Source development (the serious version)]
> 
> 
> On Wed, Jan 23, 2002 at 03:22:43PM +0200, Shlomi Fish wrote:
> > 
> > Judging by the commentary I received it seems that even we have
> > disagreements on what the OS equivalents for the Joel Test 
> Rules are. Of
> > course, AFAIK, Joel Spolsky formulated the Joel Test alone, 
> and eventually
> > people took it for granted, because of his prestigue. But I 
> believe many
> > commercial software veterans will be able to formulate 
> their own tests,
> > which may differ from the Joel Test.
> 
> But of course... There is not always concensus on what are good 
> development practices, judging even by the limited set of 
> contradicting attitudes that I am aware of.
> 

AFAIK, Joel's test is a simplified version of McConnel's one.

> Which is an interesting question (at least to me...) Is "software 
> engineering" any more of a science than economics or theology is?
> Personal taste and a vague idea of what /doesn't/ work?

Software engineering is engineering. Not a sciense.

> 
> ------------------------ Yahoo! Groups Sponsor 
> ---------------------~-->
> Sponsored by VeriSign - The Value of Trust
> When building an e-commerce site, you want to start with a
> secure foundation. Learn how with VeriSign's FREE Guide.
> http://us.click.yahoo.com/kWSNbC/XdiDAA/yigFAA/saFolB/TM
> --------------------------------------------------------------
> -------~->
> 
> To unsubscribe from this group, send an email to:
> [email-masked]
> 
>  
> 
> Your use of Yahoo! Groups is subject to 
http://docs.yahoo.com/info/terms/

---

From: Nimster <[email-masked]>
Date: Wed, 23 Jan 2002 19:10:31 +0200

> Software engineering is engineering. Not a sciense.

Is computer science a science then? (I'd say yes, but then again, I'd say
yes to engineering in general)
What's the difference between SE and CS?

-Nimster

---

From: "Gilad Ben-Yossef" <[email-masked]>
Date: Wed, 23 Jan 2002 21:13:54 +0200

> What's the difference between SE and CS?

Computer Science is a science. It is a branch of logic and Discrete mathmathics that deals in questions of formal systems, compuability and related areas. Strangly enough, this have (almost) nothing to do with computers. As a matter of fact Computer Science *predates* computers... The fact that the theortical discussion of these questions proved to be useful to building what we now call computers is a blessed accident, nothing more.

Perhaps the most astountiding (to a layman at least ) application of Computer Science, is the fact that it revelas to us that Software Engineering is nothing more then an art (and a black art at that!), certinly not engineering: 

You can't have any "dumb" proccess by which you show that a program works. Not in the sense that it produces a desired output, or any output (halts) or even not crashes.

Just think what would you say to a bridge builder that would tell you that there is no way to asseest if the bridge he designed is not going to crash when someone would step on it besides a formal proof!

Programing is an art form, but it takes a degree in computer sceince (or equivilent understaing) to understand this.

Gilad.
-- 
Gilad Ben-Yossef <[email-masked]>
Tel: +972(9)9717330 | Fax: +972(9)9717334   | Cel: +972(54)756701
Kagoor Networks ltd | http://www.kagoor.com |