Subject: RE: [hackers-il] Random thought on program sizes

From: Chen Shapira <[email-masked]>
Date: Sun, 9 Jul 2000 13:00:23 +0200

> Which leads me to the (meaningless, really) rule of thumb 
> that compilers
> are generally about twice as big as kernels.

MSdevstudio is way bigger than NT. including servicepacks and option packs.

but I think that sun's cc is smaller than solaris.

wasn't there a competition awhile back for the world's smallest c compiler?
what about kernels how small can a kernel be?

---

From: Omer Mussaev <[email-masked]>
Date: Sun, 09 Jul 2000 13:47:13 +0300

> what about kernels how small can a kernel be?

Exo claims to occupy less than 4 k in memory.
On the other side, MS-DOG occupied even less.
Well, that's not an example of a jernel:)

> ------------------------------------------------------------------------
> Remember four years of good friends, bad clothes, explosive chemistry
> experiments.
> http://click.egroups.com/1/5532/12/_/_/_/963137134/
> ------------------------------------------------------------------------
>
> To unsubscribe from this group, send an email to:
> [email-masked]

--
Omer Mussaev    051-308-214   mailto:[email-masked]
systems programmer, Mercury Interactive/RND/Conduct/core