Subject: RE: [hackers-il] Consciously Writing Bad Code

From: Chen Shapira <[email-masked]>
Date: Sun, 19 May 2002 13:49:57 +0300

> Most of the code I write now is not mission-critical and I can always
> re-factor it later. So the question is whether when I program for a
> living, I should make sure I have more discipline and write 
> the code well
> in the first place.

Think of it the other way. Most of what you write now is "practice"
programs. You are learning what methodology and practices work for you,
trying out things you heard of, etc.

In my practice code, I work very very hard to make it as modular and perfect
as possible, muhc more than necessary, because I believe that if I practice
writing modular code, it'll be easier for me to do modular code later on. 
If I manage to get to a point where writing good code is infact quicker and
easier for me than writing bad code, its a real win!

---

From: "Ofir Carny" <[email-masked]>
Date: Sun, 19 May 2002 16:26:15 +0200

When I write throwaway/one-time use utility/proof of concept code, I usually omit most error checking, I think it is bad code but a good practice, it reduces development time considerably (especially because I remember how most library functions I use work, but not how they fail).

		Ofir

********************************************************
This email has been scanned by Port Authority.

********************************************************

---

From: "Arik Baratz" <[email-masked]>
Date: Sun, 19 May 2002 16:36:57 +0200

And then your code gets embedded, in one way or another, into other pieces of code which go into production. Been there, done that.

-- Arik

-----Original Message-----
From: Ofir Carny 
Sent: Sunday, May 19, 2002 4:26 PM
To: [email-masked]
Subject: RE: [hackers-il] Re: Consciously Writing Bad Code

		Ofir

To unsubscribe from this group, send an email to:
[email-masked]

Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/