Subject: RE: [hackers-il] Idea: Worm with EULA

From: Omer Musaev <[email-masked]>
Date: Mon, 24 Sep 2001 18:51:52 +0200

> -----Original Message-----
> From: Nadav Har'El [mailto:[email-masked]]
> Sent: Monday, September 24, 2001 6:18 PM
> To: [email-masked]
> Subject: Re: [hackers-il] Idea: Worm with EULA

> Anybody else has good ideas for hacker-related practical jokes?

I recall one joke that was supposet to be nice one, but had been ruined.

One of my co-eds was toying with ~/.Xresources, trying to russify as much of

X-windows. It came to us that we can rusify someone's netscape. 
It was supposed to be a good joke, and we went all the way through
Netscape's 
menus choosing the right word for an entity. The problem was that as in
hebrew, 
almost no-one is using proper terms in native language, but rather some mix
of english
terms, jargon terms and analogies ( how many of you say "mehader", or
"mekasher" while 
compiling a program? ). 

After a successful compilation of those terms we put the pathced
./.Xresources into 
the student's ( who was friend of both of us ) account. 

After a week or so, we asked the student what he thought of the joke. 
Guess what?
HE DID NOT NOTICE the difference!!!
 
-- 
Omer Mussaev
Mercury Interactive / Topaz Prism R&D
Core Technologies team

---

From: Tzafrir Cohen <[email-masked]>
Date: Mon, 24 Sep 2001 22:01:27 +0200 (IST)

On Mon, 24 Sep 2001, Omer Musaev wrote:

> menus choosing the right word for an entity.

FYI, Xlib allows you to load a seperate set of X resources for a program
depending on the current locale settings. Mandrake actually have packages
netscape-fr, netscape-es , etc. that add
/etc/X11/{fr|es|...}/app-defaults/Netscape

You can also use $HOME/{fr|es|...}/Netscape to override the system
defaults.

With netscape you can indeed override all of their user interface (as well
as their keyboard shortcuts and a host of other stuff) using X resources.

-- 
Tzafrir Cohen
mailto:[email-masked]
http://www.technion.ac.il/~tzafrir