Subject: RE: [hackers-il] Another Interesting Case Study: Permutations of a range of characters

From: Omer Musaev <[email-masked]>
Date: Tue, 15 Jan 2002 14:49:45 +0200

> -----Original Message-----
> From: mulix [mailto:[email-masked]]
> Sent: Tuesday, January 15, 2002 2:28 PM
> To: [email-masked]
> Subject: Re: [hackers-il] Another Interesting Case Study: Permutations
> of a range of characters
> 
> 
> one nit pick, if i may [and even if i may not]:
> 
> the original c program contained a malloc(), witout checking of its
> return value. did no one else notice this, or am i the only nit picker
> in our midst? ;)

yes, and in addition it passed wrong argument to malloc ( sizeof(len)+1
instead of len +1 ). But IMHO, yes, it you are the only nit picker in
our midst.

> -- 
> mulix
> 
> http://vipe.technion.ac.il/~mulix/
> http://syscalltrack.sf.net/
> 
> 
> 
> 
> ------------------------ Yahoo! Groups Sponsor 
> ---------------------~-->
> Tiny Wireless Camera under $80!
> Order Now! FREE VCR Commander!
> Click Here - Only 1 Day Left!
> http://us.click.yahoo.com/WoOlbB/7.PDAA/ySSFAA/saFolB/TM
> --------------------------------------------------------------
> -------~->
> 
> To unsubscribe from this group, send an email to:
> [email-masked]
> 
>  
> 
> Your use of Yahoo! Groups is subject to 
> http://docs.yahoo.com/info/terms/ 
> 
>

---

From: Shlomi Fish <[email-masked]>
Date: Wed, 16 Jan 2002 08:41:25 +0200 (IST)

> instead of len +1 ). But IMHO, yes, it you are the only nit picker in

Shoot! One really should substitute sizeof(len) by len.

Regards,

	Shlomi Fish

----------------------------------------------------------------------
Shlomi Fish        [email-masked]
Home Page:         http://t2.technion.ac.il/~shlomif/
Home E-mail:       [email-masked]

"Let's suppose you have a table with 2^n cups..."
"Wait a second - is n a natural number?"