Subject: RE: [hackers-il] RE: RE: Re: Wolfram's A New Kind of Science

From: "Ofir Carny" <[email-masked]>
Date: Mon, 20 May 2002 14:12:24 +0200

This cannot be described as mesurement, because it only gives a lower bound, 
unless you rule out all shorter options as part of the measurement.

-----Original Message-----
From: Shlomi Fish [mailto:[email-masked]]
Sent: Monday, May 20, 2002 1:00 PM
To: [email-masked]
Subject: [hackers-il] RE: RE: Re: Wolfram's A New Kind of Science

On Mon, 20 May 2002, Arik Baratz wrote:

>
> The amount of information in pi is very small - I can contain all that
> information within the sentance 'the ratio between the circumference of
> a circle and its radius'. The program that calculates pi is just a fancy way
> to say that.
>
> -- Arik
>

Actually, sentences are not an objective (mathematically) way to measure
an amount of information. I can describe an object as "the text of the
bible". It's a very short sentence, but the amount of information here is
huge.

The only objective way to measure the amount of information in a given
data is to write a computer program that will output it to the screen.

Regards,

	Shlomi Fish

> -----Original Message-----
> From: Shlomi Fish [mailto:[email-masked]]
> Sent: Monday, May 20, 2002 7:09 AM
> To: [email-masked]
> Subject: RE: Re: Wolfram's A New Kind of Science
>
>
> On Sun, 19 May 2002, Ofir Carny wrote:
>
> > I think that he meant is that Pi is a constant whose representation is infinite,
> > but we can write a finite program to output it up to the Nth digit, given enough time
> > (actually O(N)), the output is only approximate after the Nth digit.
> >
> > Note that it is trivially easy to prove that not all irrational numbers can be represented
> > in a similar manner. Corralary - Pi is not really that complex, very similarily to fractals.
> >
>
> What I meant is that indeed the computer program required to produce that
> output has O(1) size. Thus, according to Information Theory the amount of
> information contained in it is O(1).
>
> Regards,
>
> 	Shlomi Fish
>
> > -----Original Message-----
> > From: Tzafrir Cohen [mailto:[email-masked]]
> > Sent: Sunday, May 19, 2002 6:50 PM
> > To: [email-masked]
> > Subject: Re: Re: Wolfram's A New Kind of Science
> >
> > >
> > > Well, the Mandelbrot Set seems very complex to us, and it is generated
> > > from a very simple algorithm. It has O(1) information. For that matter, pi
> > > or e or the square root of two, have O(1) information and it is conjured
> > > (or proven) that their representation contains every possible sequence
> > > that can be generated.
> >
> > The O) notation is not relevant here. It is relevant when you can talk of
> > a parametrized resource (e.g: exeution time as a function of the input
> > size). pi is a constant.
> >
> > Note that using rational numbers we can only get an approximated value of
> > irrational values, such as pi, e and sqrt(2). This can create some
> > oddities as mentioned above.
> >
> >
> >
> > To unsubscribe from this group, send an email to:
> > [email-masked]
> >
> >
> >
> > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
> >
> >
> >
> > *
> >  *******************************************************
> > This email has been scanned by Port Authority.
> >
> > ********************************************************
> >
> >
> >
> > To unsubscribe from this group, send an email to:
> > [email-masked]
> >
> >
> >
> > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
> >
> >
>
>
>
> ----------------------------------------------------------------------
> Shlomi Fish        [email-masked]
> Home Page:         http://t2.technion.ac.il/~shlomif/
> Home E-mail:       [email-masked]
>
> "Let's suppose you have a table with 2^n cups..."
> "Wait a second - is n a natural number?"
>
>
>
> To unsubscribe from this group, send an email to:
> [email-masked]
>
>
>
> Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
>
>
>
>
> To unsubscribe from this group, send an email to:
> [email-masked]
>
>
>
> Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
>
>

----------------------------------------------------------------------
Shlomi Fish        [email-masked]
Home Page:         http://t2.technion.ac.il/~shlomif/
Home E-mail:       [email-masked]

"Let's suppose you have a table with 2^n cups..."
"Wait a second - is n a natural number?"

To unsubscribe from this group, send an email to:
[email-masked]

Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/

---

From: Shlomi Fish <[email-masked]>
Date: Mon, 20 May 2002 14:20:22 +0300 (IDT)

> unless you rule out all shorter options as part of the measurement.

Were you replying to Arik or to me?

Regards,

	Shlomi Fish

> Subject: RE: RE: Re: Wolfram's A New Kind of Science
>
>