Subject: RE: [hackers-il] "Structure of OS" Course and Real Life

From: Chen Shapira <[email-masked]>
Date: Thu, 15 Nov 2001 09:24:54 +0200

> -----Original Message-----
> From: Nadav Har'El [mailto:[email-masked]]
> Sent: Thursday, November 15, 2001 12:28 AM
> To: [email-masked]
> Subject: Re: [hackers-il] "Structure of OS" Course and Real Life
> 
> 
> On Wed, Nov 14, 2001, Shlomi Fish wrote about "[hackers-il] 
> "Structure of OS" Course and Real Life":
> > 
> > After I studied the EE "Structure of OS" course, it is my 
> opinion that it
> >..
> > As a small example let's take the common paradigm that says 
> that if I have
> > a lot of homework to do, I'll start with the easiest ones 
> first. This is a
> > variation of the Shortest-Job First (SJF) algorithm in 
> process scheduling.
> >..
> > Do you share my opinion (or oppose it), or can relate a 

> 4. User Friendliness and Graphical User Interface:
>    Most people are not very user-friendly. Try talking to a 
> person (especially
>    of the opposite sex) and trying to guess what you're 
> supposed to do now,
>    what the other person wants from you, what would happen if 
> you did this,
>    and what would happen if you did that, and how the heck to 
> you get the
>    other person to do what you really want. No more of that! 
> People should
>    get a graphical user interface. Why talk to the other 
> person in that
>    complex command line language we call "Hebrew", when you 
> can just look at
>    the menu, see the options "Leave me alone" and "Let's have 
> sex" and just
>    chose the one you want! Better yet, why not have a 
> toolbar, with nice little
>    icons?

I have to remark that the complex command line interface called "Hebrew"
doesn't work in most enviroments, and therefore you need to have access to a
more portable API called "English".

Few days ago, in a book store, I saw a small booklet with lots of small
pictures of everyday things. The instructions, written in a command line
interface, said that you should use this book if another person doesn't have
a common language with you. You can just point and click.

So I guess real life has its GUI :-)

Chen.

---

From: Omer Musaev <[email-masked]>
Date: Thu, 15 Nov 2001 16:08:06 +0200

> From: Adi Stav [mailto:[email-masked]]
> Sent: Thursday, November 15, 2001 2:59 PM
... 
> Indeed. I think Al Viro is the only American citizen among the very

Al was born in Russia, so he can be called European too....