Subject: RE: [hackers-il] NDAs [was RE: Looking for a Job : Shlomi Fish' Bio]

From: "Arik Baratz" <[email-masked]>
Date: Thu, 14 Nov 2002 17:01:14 +0200

> -----Original Message-----
> From: Shlomi Fish [mailto:[email-masked]]

> > > 1. I will not sign an NDA.
> > Why will you not sign an NDA? Just out of curiosity.
> 
> Simple - I can tell you exactly what I did at each one of my previous
> workplaces. And I can tell spicy details from there.
> 
> I like the fact that I can tell what is going on in my 
> workplace and what
> I do to other people, without having to keep it all inside. 
> And with my
> tendency to become euphoric, this becomes a necessity.

Well, usually the NDA deals with trade secrets, source code, etc. and just saying that I wrote a piece of code using ADSI and I used their search interface to search for a user using an LDAP-style query, won't get me in trouble. Even providing a sample snippet won't - I have done this many times, either to get help with my code or to give help.

I don't know what NDA you came across, but mine doesn't disallow talking about stuff that happens in the workplace.

My suggestion to you is not to overrule NDAs categorically. Read everything you sign on, though.

-- Arik

> 
> Joel Spolsky has a nice piece about it:
> 
> http://www.joelonsoftware.com/articles/fog0000000071.html
> 
> Naturally, I'm not going to convey every little piece of code I see or
> publish it on the Net. But I like the fact that there isn't 
> an element of
> secrecy. Secrets don't scale.

---

From: Shlomi Fish <[email-masked]>
Date: Fri, 15 Nov 2002 11:27:40 +0200 (IST)

On Thu, 14 Nov 2002, Arik Baratz wrote:

> My suggestionto you is not to overrule NDAs categorically. Read everything you sign on, though.
>

Okay, in that case, I guess I can sign most NDAs. I'll modify it in the
last post.

Regards,

	Shlomi Fish

> To unsubscribe from this group, send an email to:
> [email-masked]
>
>
>
> Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
>
>

----------------------------------------------------------------------
Shlomi Fish        [email-masked]
Home Page:         http://t2.technion.ac.il/~shlomif/
Home E-mail:       [email-masked]

"Let's suppose you have a table with 2^n cups..."
"Wait a second - is n a natural number?"

---

From: Muli Ben-Yehuda <[email-masked]>
Date: Fri, 15 Nov 2002 11:33:46 +0200

> Okay, in that case, I guess I can sign most NDAs. I'll modify it in the

You mean there's a list that hasn't seen your "looking for work" post
yet??? 

*prays it's not Linux kernel* 

Seriously, if you don't know about it, check out
http://www.cji.co.il/, they have good stuff occasionally. Good luck. 
-- 
Muli Ben-Yehuda				    http://www.mulix.org/
[email-masked]:~$ sctrace strace /bin/foo  http://syscalltrack.sf.net/
Quis custodes ipsos custodiet?              http://www.mulix.org/cv.html

---

From: Shlomi Fish <[email-masked]>
Date: Fri, 15 Nov 2002 11:30:58 +0200 (IST)

> *prays it's not Linux kernel*

LOL.

Regards,

	Shlomi Fish

> http://www.cji.co.il/, they have good stuff occasionally. Good luck.

Thanks.

> [email-masked]:~$ sctrace strace /bin/foohttp://syscalltrack.sf.net/