Subject: RE: [hackers-il] gvim for LISP editing [was RE: Re: Scheme in C I ndentation Cont.]

From: Omer Musaev <[email-masked]>
Date: Thu, 14 Mar 2002 11:41:41 +0200

> -----Original Message-----
> From: Shlomi Fish [mailto:[email-masked]]
> Sent: Thursday, March 14, 2002 11:31 AM
> To: [email-masked]'
> Subject: [hackers-il] gvim for LISP editing [was RE: Re: Scheme in C
> Indentation Cont.]
> 
> 
> On Thu, 14 Mar 2002, Omer Musaev wrote:
> 
> >
> >
> > > -----Original Message-----
> > > From: Shlomi Fish [mailto:[email-masked]]
> > > Sent: Wednesday, March 13, 2002 8:30 PM
> > > To: [email-masked]
> > > Subject: [hackers-il] Re: Scheme in C Indentation Cont.
> > >
> > >
> > > On 13 Mar 2002, Oleg Goldshmidt wrote:
> > >
> > > > Shlomi Fish <[email-masked]> writes:
> >
> > (let ((it "paren higlighting"))
> >
> 
> What is the meaning of this LISP-like directive?
42.
 
> > > Are you aware of any way to turn it on in gvim? I can go 
> to a matching
> > > parens with "%", but I don't know how to highlight it as 
> I type it.
> >
> > :set lisp, of course:)
> 
> It does not do it in gvim 6.0. Nor is supposed to, according 
> to the help
> file.
> 
> > BTW: why gvim? gvim is not good at interactive programming at all...
> 
> You mean the standard Ctrl+X Ctrl+E and other Emacs/Edwin 
> stuff? Well, my
> style is to write my code in gvim, load it there, run it, modify it in
> gvim, etc. until it works perfectly and is bug free.
> 
> I hate working inside Edwin. As for Emacs, I only use it for 
> ispell-buffer
> at the moment, because I don't like it too much. Whenever I tried to
> seriously get accustomed to it, there was some obstacle which 
> I could not
> quite overcome that made my editing a living hell.

Got it.
 
> So I'm directing my plea to Muli or Nadav or whoever is 
> proficient enough
> in Emacs and would like to give a lecture about it, 
> preferably followed by
> a Q&A session.

Google for Emacs tutorial, of C-H t . There is a plenty of such 
a stuff on the web.

> Best regards,
> 
> 	Shlomi Fish
> 
> > )
> >
> >
> > > Regards,
> > >
> > > 	Shlomi Fish
> > >
> > >
> > > > --
> > > > Oleg Goldshmidt | [email-masked]
> > > > [Lisp] is the only computer language that is beautiful.
> > > >                       - Neal Stephenson
> > > >
> > > >
> > > > To unsubscribe from this group, send an email to:
> > > > [email-masked]
> > > >
> > > >
> > > >
> > > > Your use of Yahoo! Groups is subject to
> > > http://docs.yahoo.com/info/terms/
> > > >
> > > >
> > >
> > >
> > >
> > > 
> ----------------------------------------------------------------------
> > > Shlomi Fish        [email-masked]
> > > Home Page:         http://t2.technion.ac.il/~shlomif/
> > > Home E-mail:       [email-masked]
> > >
> > > "Let's suppose you have a table with 2^n cups..."
> > > "Wait a second - is n a natural number?"
> > >
> > >
> > > ------------------------ Yahoo! Groups Sponsor
> > > ---------------------~-->
> > > Tiny Wireless Camera under $80!
> > > Order Now! FREE VCR Commander!
> > > Click Here - Only 1 Day Left!
> > > http://us.click.yahoo.com/nuyOHD/7.PDAA/yigFAA/saFolB/TM
> > > --------------------------------------------------------------
> > > -------~->
> > >
> > > To unsubscribe from this group, send an email to:
> > > [email-masked]
> > >
> > >
> > >
> > > Your use of Yahoo! Groups is subject to
> > > http://docs.yahoo.com/info/terms/
> > >
> > >
> >
> >
> > To unsubscribe from this group, send an email to:
> > [email-masked]
> >
> >
> >
> > Your use of Yahoo! Groups is subject to 
> http://docs.yahoo.com/info/terms/
> >
> >
> 
> 
> 
> ----------------------------------------------------------------------
> Shlomi Fish        [email-masked]
> Home Page:         http://t2.technion.ac.il/~shlomif/
> Home E-mail:       [email-masked]
> 
> "Let's suppose you have a table with 2^n cups..."
> "Wait a second - is n a natural number?"
> 
> 
> ------------------------ Yahoo! Groups Sponsor 
> ---------------------~-->
> Tiny Wireless Camera under $80!
> Order Now! FREE VCR Commander!
> Click Here - Only 1 Day Left!
> http://us.click.yahoo.com/nuyOHD/7.PDAA/yigFAA/saFolB/TM
> --------------------------------------------------------------
> -------~->
> 
> To unsubscribe from this group, send an email to:
> [email-masked]
> 
>  
> 
> Your use of Yahoo! Groups is subject to 
> http://docs.yahoo.com/info/terms/ 
> 
>

---

From: Shlomi Fish <[email-masked]>
Date: Thu, 14 Mar 2002 12:34:33 +0200 (IST)

Hi OmerM and Muli!

I read the Emacs Tutorial, but it did not teach everything I need to know.
I can't remember what stuff irked me the last time I tried to use XEmacs,
but I remember it was something that was quite trivial to do in gvim, the
way I configured it.

How about that: I'll try to use Emacs to do some of my work. Whenever I
encounter something there that I wish to have and I cannot find it, can I
ask this list for assisstance?

Regards,

	Shlomi Fish

---

From: mulix <[email-masked]>
Date: Thu, 14 Mar 2002 12:56:56 +0200

> ask this list for assisstance?

no. 
this list is 'hackers-il', not
'gvim/latex/emacs/perl/scheme/python/tying my shoelaces' support. it
should have interesting, *hacking related* posts. emacs questions
should go to one of the emacs mailing lists or newgroups(*). that having
been said, you're more than welcome to ask me any emacs related
questions - in private. 

(*) unless they have bigger than 0 hack value, of course. 
-- 
The ill-formed Orange		
Fails to satisfy the eye:       http://vipe.technion.ac.il/~mulix/ 
Segmentation fault.		http://syscalltrack.sf.net/

---

From: Tzafrir Cohen <[email-masked]>
Date: Thu, 14 Mar 2002 13:23:23 +0200 (IST)

> ask this list for assisstance?

Alternatively, try some emacs lists/groups

-- 
Tzafrir Cohen                        /"\
mailto:[email-masked]        \ /  ASCII Ribbon Campaign
Taub 229, 972-4-829-3942,             X   Against  HTML  Mail
http://www.technion.ac.il/~tzafrir   / \

---

From: Oleg Goldshmidt <[email-masked]>
Date: 14 Mar 2002 16:14:28 +0200

mulix <[email-masked]> writes:

> emacs questions should go to one of the emacs mailing lists or
> newgroups

comp.emacs, comp.emacs.xemacs

> been said, you're more than welcome to ask me any emacs related

second that - what's the community for.