Subject: RE: [hackers-il] Summary of a Bash Lecture

From: Chen Shapira <[email-masked]>
Date: Tue, 31 Oct 2000 09:38:26 +0200

> simple readline quickies:
> 
> arrows - history
> ^-r  find command in history by name
> 
> readline is NOT shell

And the ! command to use the history

---

From: Chen Shapira <[email-masked]>
Date: Thu, 2 Nov 2000 08:48:11 +0200

> > Never implement yourself using shell what is already 
> implemented with C.
> 
> This is a tautology, and a biased one at that (if you remove 
> the words "shell"
> and "C", the sentence will still be true, and all you did was 
> added a bias
> against the shell) ;)

not necessarily - if something is implemented in C - you may be able to do a
better job implementing it in C yourself.
Same thing if something is in shell.
But you can't outperform a C program with shell.
Although if something was written in shell, you may want to implement it
again with C for performance issues.

Which means - if I reverse "shell" and "C" we no longer have a true
sentence, so its not a tautology.

Which reminds me, does anyone has used math books from previous years in the
university that he/she can sell/lend?