Subject: RE: [hackers-il] We had computer viruses. Now tumors?

From: Omer Musaev <[email-masked]>
Date: Mon, 25 Mar 2002 18:59:59 +0200

> -----Original Message-----
> From: Nadav Har'El [mailto:[email-masked]]
> Sent: Monday, March 25, 2002 6:56 PM
> To: [email-masked]
> Subject: Re: [hackers-il] We had computer viruses. Now tumors?
> 
[ skipped explanation on why some resources are used even by NOPs ]

> If I remember correctly, there's also a system-wide limit to 
> the number of
> processes in Linux, in
> /proc/sys/kernel/threads-max.

And yet another limit that is compiled in... so that root will not try to
run 2^40
 processes ( /proc limit is mutable ).

> 
> 
> -- 
> Nadav Har'El                        |       Monday, Mar 25 
> 2002, 13 Nisan 5762
> [email-masked]             
> |-----------------------------------------
> Phone: +972-53-245868, ICQ 13349191 |An egotist is a person 
> of low taste, more
> http://nadav.harel.org.il           |interested in himself than in me.

---

From: Omer Musaev <[email-masked]>
Date: Mon, 25 Mar 2002 19:18:33 +0200

> From: Dan Kenigsberg [mailto:[email-masked]]
> Sent: Monday, March 25, 2002 7:06 PM
> Which reminds me of a method used to put out burning Kuwaiti 
> oil wells:
> drop a small bomb on top of it. when the bomb explodes, it 
> suffocates the flame.
> 

Which reminds me of story about using nuclear bomb to extinguish 
underground fire

http://www.vniief.ru/museum/museum_e.html

> > 
> > 
> > A running process is a resource.
> > 
> > The fork bomb spawned short-lived processes en masse. The 
> antidote competes
> > for the same resource (number of processes) but once it has 
> a process it
> > will not relinquish it for 100 seconds. This starves the 
> fork-bomb on one
> > hand but frees the CPU on the other.
> > 
> 
> ------------------------ Yahoo! Groups Sponsor 
> ---------------------~-->
> Tiny Wireless Camera under $80!
> Order Now! FREE VCR Commander!
> Click Here - Only 1 Day Left!
> http://us.click.yahoo.com/nuyOHD/7.PDAA/yigFAA/saFolB/TM
> --------------------------------------------------------------
> -------~->
> 
> To unsubscribe from this group, send an email to:
> [email-masked]
> 
>  
> 
> Your use of Yahoo! Groups is subject to 
> http://docs.yahoo.com/info/terms/ 
> 
>