Subject: RE: [hackers-il] Do the Borg own assimilated cultures, or did the y inherit them?

From: Omer Musaev <[email-masked]>
Date: Tue, 31 Jul 2001 11:36:39 +0200

> -----Original Message-----
> From: Omer Zak [mailto:[email-masked]]
> Sent: Tuesday, July 31, 2001 9:05 AM
> To: [email-masked]
> Subject: [hackers-il] Do the Borg own assimilated cultures, 
> or did they
> inherit them?
> 
> 
> Among two objects A,B of classes Ca,Cb (respectively), there 
> can be three
> relationships:
> A uses-a B - one of the members of A points at an instance of 
> B, but A is
>              not responsible for destroying B when A goes out of
>              existence.  There needs to be no special 
> relationship between
>              Ca and Cb.
> A owns-a B - same as the above except that A is responsible 
> for destroying
>              B when it goes out of existence.
> A is-a Cb  - A is inherits from Cb, or equivalently, Ca uses-a Cb.
>              Since Ca has no meaning when Cb goes out of 
> scope, Cb can be
>              consider to own-a all its subclasses.
> (What about interfaces?  Can one class actually inherit from 
> another class
> rather than have an uses-a relationship?)
> 
> Now, after the Borg assimilated Geinan's race, they (as a 
> class) use the
> class whose members are the people of Geinan's race.  The information
> about Geinan's race also would get lost when the Borg go out 
> of existence,
> except for any information remembered by Geinan herself.
> 
> However, since the Borg can exist independently of Geinan's race, they
> don't inherit from each other.  Their relationship is 
> formally of uses-a
> type - as they are not always successful in converting all members of
> assimilated races.

Definitely, Borg are implemented using the Visitor pattern...

>                                              --- Omer
> There is no IGLU Cabal.  Marc the Terrible has assimilated all of the
> former IGLU Cabal members, under the threat of his formidable 
> Differential
> SCSI Cable.
> WARNING TO SPAMMERS:  at http://www.zak.co.il/spamwarning.html
> 
> 
> ------------------------ Yahoo! Groups Sponsor 
> ---------------------~-->
> Small business owners...
> Tell us what you think!
> http://us.click.yahoo.com/vO1FAB/txzCAA/ySSFAA/saFolB/TM
> --------------------------------------------------------------
> -------~->
> 
> To unsubscribe from this group, send an email to:
> [email-masked]
> 
>  
> 
> Your use of Yahoo! Groups is subject to 
> http://docs.yahoo.com/info/terms/ 
> 
>

---

From: Omer Musaev <[email-masked]>
Date: Tue, 31 Jul 2001 11:41:56 +0200

> Definitely, Borg are implemented using the Visitor pattern...

Just as Julius Caesar did before...

-- 
Omer Mussaev
Mercury Interactive / Topaz Prism R&D
Core Technologies team