Subject: RE: [hackers-il] Re: Wolfram's A New Kind of Science

From: "Ofir Carny" <[email-masked]>
Date: Sun, 19 May 2002 19:57:12 +0200

I think that he meant is that Pi is a constant whose representation is infinite, 
but we can write a finite program to output it up to the Nth digit, given enough time
(actually O(N)), the output is only approximate after the Nth digit.

Note that it is trivially easy to prove that not all irrational numbers can be represented
in a similar manner. Corralary - Pi is not really that complex, very similarily to fractals.

-----Original Message-----
From: Tzafrir Cohen [mailto:[email-masked]]
Sent: Sunday, May 19, 2002 6:50 PM
To: [email-masked]
Subject: Re: [hackers-il] Re: Wolfram's A New Kind of Science

>
> Well, the Mandelbrot Set seems very complex to us, and it is generated
> from a very simple algorithm. It has O(1) information. For that matter, pi
> or e or the square root of two, have O(1) information and it is conjured
> (or proven) that their representation contains every possible sequence
> that can be generated.

The O) notation is not relevant here. It is relevant when you can talk of
a parametrized resource (e.g: exeution time as a function of the input
size). pi is a constant.

Note that using rational numbers we can only get an approximated value of
irrational values, such as pi, e and sqrt(2). This can create some
oddities as mentioned above.

To unsubscribe from this group, send an email to:
[email-masked]

Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/

*
 *******************************************************
This email has been scanned by Port Authority.

********************************************************

---

From: Shlomi Fish <[email-masked]>
Date: Mon, 20 May 2002 08:08:33 +0300 (IDT)

> in a similar manner. Corralary - Pi is not really that complex, very similarily to fractals.

What I meant is that indeed the computer program required to produce that
output has O(1) size. Thus, according to Information Theory the amount of
information contained in it is O(1).

Regards,

	Shlomi Fish

> Subject: Re: Re: Wolfram's A New Kind of Science
>
> >

----------------------------------------------------------------------
Shlomi Fish        [email-masked]
Home Page:         http://t2.technion.ac.il/~shlomif/
Home E-mail:       [email-masked]

"Let's suppose you have a table with 2^n cups..."
"Wait a second - is n a natural number?"