Subject: [META] hackers-il guidelines

From: [email-masked]
Date: Thu, 11 May 2000 15:53:23 +0300

hackers-il was started for 3 reasons:
- creating a mailing list where one can discuss interesting computer related
  issues
- create a community that'll meet, have fun and discuss interesting computer
  things
- start producing great hacks for everyone's benefit

The first mission is advancing well - with very few exceptions, we have a great
mailing list.

The third target is not an issue right now and will be dealt with later.
Well, some members have contributed very cool hacks, so we are on the right way
on this front too.

I'm worried about the second goal though.

we currently have O(30) subscribers, most of them are very very quite. This can
be a problem. If I'd like to have a hackers-il meeting in my home, I risk
hosting 30 total strangers.

scary

here's my idea:

We can have 2 kinds of members, lets call them "hackers" and "lurkers".

Anyone who subscribes to the list is a lurker, a lurker may  listen to the conversation, but he may not post to the mailing list, and he may not attend parties.

A lurker who wants to become a hacker, should send the mailing list a 200 lines
article or code, if we decide its cool, he's a hacker.  

If a person feels he should be a hacker but doesn't want to send code or
 article, he should email [email-masked] in rivate and explain why he's a hacker.

In any case - the guy should be be aware that we may want to ask him some questions.  

If a person doesn't think he's a hacker but wants to attend a party anyhow, he should write the same address and explain why. strong background or interest in a specific subject is a good excuse. ("I'm not a hacker yet, but I love perl, worship shlomi, and I'd do anything to hear him talk about cool perl hacks").
  
 If someone doesn't know much about the subject but wants to attend the
 party anyway - we can be bribed with beer and complements.

 I hope you find these reasonable.

 BTW. anyone who already wrote cool stuff to the list, doesn't have to
 send the article/code. If
 you are in doubt - ask me personally.

--
Chen Shapira	Web Developer and Linux Activist
The algorithm for finding the longest path in a graph is NP-complete.
For you systems people, that means it's *real slow*.

---

From: Omer Zak <[email-masked]>
Date: Thu, 11 May 2000 22:08:57 +0300 (IDT)

Hello Chen,

> - start producing great hacks for everyone's benefit

[... some ideas were snipped ...]

> A lurker who wants to become a hacker, should send the mailing list a
> 200 lines article or code, if we decide its cool, he's a hacker. 

May I suggest that the requirement for 200 lines long article be dropped.
The shorter is an article, which makes a point, the cooler it is.
Certainly, some of the most artistic of Marc Volovic's flames during the
"good ol' days" qualify as cool articles.

(Here I claim a point of coolness, because I claim that something which is
very hot is cool as well.  Fits with the statistical physical definition
of temperature, which considers infinitely high temperatures as equivalent
to negative temperatures.)

>  party anyway - we can be bribed with beer and complements.

Please add also laptop+agreement to volunteer to take notes during the
party in behalf of the small (but larger than 1!) population of deaf
hackers in this mailing list.  (Only kidding :-) )

Another suggestion for a hacking project is to design a shorter anti-spam
warning, which will squeeze into less lines the same legal protection
afforded by my present 5-line long anti-spam magic spell.

                                             --- Omer
   "MS-Word keeps thinking it knows what I'm gonna do next and tries to
   help me.  I've lived with my wife for 27 years and SHE can't do that.
   What makes MS-Word think it can?"             Bill Mullins
WARNING:
By sending me unsolicited commercial/political/religious E-mail message/s
(known also as "spam"), you irrevocably agree to pay me US$500.- (plus any
legal expenses incurred by my trying to collect the amount due) per
unsolicited commercial/political/religious E-mail message - for the service
of receiving it.