Subject: More Google Fun

From: Shlomi Fish <[email-masked]>
Date: Tue, 26 Nov 2002 13:08:38 +0200 (IST)

Search Google for "%s" and you'll find the homepage of the GNU project
as the first link:

http://www.google.com/search?hl=en&lr=&ie=ISO-8859-1&q=%25s

It probably has to do with the huge amount of printf and friends that they
use in their code.

Regards,

	Shlomi Fish

----------------------------------------------------------------------
Shlomi Fish        [email-masked]
Home Page:         http://t2.technion.ac.il/~shlomif/
Home E-mail:       [email-masked]

"Let's suppose you have a table with 2^n cups..."
"Wait a second - is n a natural number?"

---

From: Omer Musaev <[email-masked]>
Date: Tue, 26 Nov 2002 17:39:27 +0200

' -----Original Message-----
' From: Adi Stav [mailto:[email-masked]]
' Sent: Tuesday, November 26, 2002 8:10 PM
' To: [email-masked]
' Subject: Re: [hackers-il] More Google Fun
' 
' 
' On Tue, Nov 26, 2002 at 01:47:40PM +0200, Omer Musaev wrote:
' > Cute. But the probable explanation does not hold, IMHO. 
' > 
' > By performing little experiment, I had found that Google search
' > silently ignores the percent character when that prepends the 
' > search phrase. In other words, searching for "s" should 
' bring us the 
' > same link as searching for "%s" would do. 
' 
' Hmm.  I'd say that this is due to the "GNU's not UNIX" name, which has
' the letter S all by itself.  Since gnu.org is very commonly 
' linked to, 
' it appears as the first result.  Look at the other results 
' for S: all the
' top results also have this form.

Sounds reasonable.
 
' Other letters lead to other pages: C is CNET, D is D-Link, B 
' is our very
' own B'Tselem, and so forth.  Fun game.

' 
' --
' "How come the paper clip doesn't creep up from behind those people 
' with `it looks like you are trying to type an English document!'?" 
' -- Ira Abramov, on MS-Word's BiDi user interface
' 
' ------------------------ Yahoo! Groups Sponsor 
' ---------------------~-->
' Get 128 Bit SSL Encryption!
' http://us.click.yahoo.com/CBxunD/vN2EAA/xGHJAA/saFolB/TM
' --------------------------------------------------------------
' -------~->
' 
' To unsubscribe from this group, send an email to:
' [email-masked]
' 
'  
' 
' Your use of Yahoo! Groups is subject to 
' http://docs.yahoo.com/info/terms/ 
' 
'