Subject: RE: [hackers-il] at which point is code worthy of publication?

From: "Ofir Carny" <[email-masked]>
Date: Thu, 14 Nov 2002 12:21:46 +0200

I would go with the rule of publishing early, that's the way to get others to join the effort (coding/testing/coming up with features).

However, make sure that the code is reasonably well written (for the coders), compiles (for the testers), and to document the features and plans for the future, plus any known bugs (in order not to waste community effort, e.g. if you plan a major code overhaul, make sure nobody will work on the current version).

---

From: Tzafrir Cohen <[email-masked]>
Date: Thu, 14 Nov 2002 13:01:11 +0200 (IST)

On Thu, 14 Nov 2002, Ofir Carny wrote:

> I would go with the rule of publishing early, that's the way to get
> others to join the effort (coding/testing/coming up with features).

Will they?

Do you know each and every program in freshemat & slashdot? Would you
bothred if the volume would have been higher?

The indexing of freshmeat is useful, but not good enough.

>
> However, make sure that the code is reasonably well written (for the
> coders), compiles (for the testers), and to document the features and
> plans for the future, plus any known bugs (in order not to waste
> community effort, e.g. if you plan a major code overhaul, make sure
> nobody will work on the current version).
>

Wow! This means that you'll know what you'll do in the future ;-)

Cheers

-- 
Tzafrir Cohen
mailto:[email-masked]
http://www.technion.ac.il/~tzafrir

---

From: Muli Ben-Yehuda <[email-masked]>
Date: Thu, 14 Nov 2002 13:56:27 +0200

> > others to join the effort (coding/testing/coming up with features).

In my experience, very very rarely. 

> bothred if the volume would have been higher?

Exactly. 

> > nobody will work on the current version).

While this is all good and sound advice, it's not what I asked. I know
how to release software that other people can and will use. I've been
doing it for a while now. What I'm speculating about (with this
group's kind help) is when should software be published, from the
"good of the public (and not the publisher)" point of view. 
-- 
Muli Ben-Yehuda				    http://www.mulix.org/
[email-masked]:~$ sctrace strace /bin/foo  http://syscalltrack.sf.net/
Quis custodes ipsos custodiet?              http://www.mulix.org/cv.html