Subject: RE: [hackers-il] Stallman's Printer Driver Test (was: RE: making a non-GPLed module)

From: Chen Shapira <[email-masked]>
Date: Wed, 28 Nov 2001 13:31:16 +0200

> Stallman's Printer Driver Test, as formulated above, has two 
> non-obvious
> consequences:
> 1. If GPLed/LGPLed code is used in embedded devices, then a 
> way needs to
>    be provided for the customer to update the code.
>    Such a requirement would have been helpful in overcoming 
> Y2K problems
>    in embedded devices, which are date-sensitive 
> (fortunately, there were
>    not too many such devices two years ago).
> 2. Test cases and test scripts should be considered as part 
> of software's
>    source code, as far as copyright and licensing are concerned:
>    Representing software in unobfuscated (SP?) source code is 
> necessary to
>    make it easy to modify the software.
>    Making test cases available is necessary to make it easy 
> to modify the
>    software, by making it safer to modify the software, by making it
>    possible to certify that one's changes do not have unintended
>    consequences.

3. Adequate documentation. Its almost the same requirment as the
"unobfuscated source code" rule.
Free software should be possible to change by people other than the original
developer,
software distributed without adequate documentation (at least on source
level) is virtually impossible to change.
Also, while writing the code, the programmer knew what he was doing, when
you look at undocumented code, you often have no idea what the coder was
doing, this hiding of vital information should be considered obfuscation.

Thanks,
Chen.

---

From: Omer Musaev <[email-masked]>
Date: Wed, 28 Nov 2001 15:36:21 +0200

> -----Original Message-----
> From: Omer Zak [mailto:[email-masked]]
> Sent: Wednesday, November 28, 2001 1:25 PM
> To: linux ILUG; [email-masked]
> Subject: [hackers-il] Stallman's Printer Driver Test (was: 
> RE: making a
> non-GPLed module)
> 

[ snipped discussion on what RMS _really_ inteneded to ]

In a way, Sun interface policy should pass the test. That is really funny, 
considering amount of hype against Sun's policy....

>                                              --- Omer
> There is no IGLU Cabal.  None of the proposals, presented to 
> the Official
> Founders of the IGLU Cabal, passed Stallman's Printer Driver Test.
> WARNING TO SPAMMERS:  at http://www.zak.co.il/spamwarning.html
> 
> 
> ------------------------ Yahoo! Groups Sponsor 
> ---------------------~-->
> Universal Inkjet Refill Kit $29.95
> Refill any ink cartridge for less!
> Includes black and color ink.
> http://us.click.yahoo.com/gwUrIA/MkNDAA/ySSFAA/saFolB/TM
> --------------------------------------------------------------
> -------~->
> 
> To unsubscribe from this group, send an email to:
> [email-masked]
> 
>  
> 
> Your use of Yahoo! Groups is subject to 
> http://docs.yahoo.com/info/terms/ 
> 
>