Subject: RE: [hackers-il] Is regression test suite really unimportant? (wa s: . . .)

From: Omer Musaev <[email-masked]>
Date: Sun, 8 Jul 2001 18:22:57 +0200

> -----Original Message-----
> From: mulix [mailto:[email-masked]]
> Sent: Sunday, July 08, 2001 3:09 PM
> To: [email-masked]
> Subject: Re: [hackers-il] Is regression test suite really unimportant?
> (was: . . .)
> 
...
> 
> could anyone recommend a good book on 'software testing'? my summer
> reading list only weighs 30 kgs at the moment :)

I do not recall nothing I"ve read about testing, but following books were
interesting:

"Writing Solid Code" by Steve McGuire has many insights.
"Practice of Programming" by Brian Kernighan and Rob Pike is a very nice
book.

> -- 
> mulix
> http://www.advogato.com/person/mulix
> 
> linux/reboot.h: #define LINUX_REBOOT_MAGIC1 0xfee1dead
> 
> 
> To unsubscribe from this group, send an email to:
> [email-masked]
> 
>  
> 
> Your use of Yahoo! Groups is subject to 
http://docs.yahoo.com/info/terms/

---

From: Eran Tromer <[email-masked]>
Date: Tue, 10 Jul 2001 15:26:14 +0200

> "Practice of Programming" by Brian Kernighan and Rob Pike is a very nice

They purport to present general principles with examples in C, but most
of the time they end up discussing idiosyncrasies and pitfalls specific
to C. So this is a great companion to "The C Programming Language", but
for the rest of the world (including C++ programmers) it's not very
helpful, apart from serving as a good reminder why they didn't choose C
in the first place. <g>

  Regards,
    Eran Tromer