Subject: Your recommendation for a bug-tracking database

From: Omer Zak <[email-masked]>
Date: Sat, 23 Nov 2002 01:52:03 +0200 (IST)

What bug-tracking database do wise&experienced hackers recommend for the
following situation:
- Linux-based server.
- Clients run Linux.  It would be nice to be able to use clients also
  under Windows 2000.
- Small group (4 programmers, 2 software testers).
- No specific licensing requirements on the software whose bugs are being
  tracked (i.e. it may be evil closed proprietary software).

Would Bugzilla (used by Mozilla and other free software projects) be
suitable for such a situation? 
                                             --- Omer
Confession:  We are trying to pass the Joel Test.
WARNING TO SPAMMERS:  see at http://www.zak.co.il/spamwarning.html

---

From: Muli Ben-Yehuda <[email-masked]>
Date: Sat, 23 Nov 2002 01:17:58 +0200

> suitable for such a situation? 

I think it will be. However, as I've never used any other bug tracking
software (barring 'M-x find-file BUGS' in emacs) I'll be interested in
hearing about comparisons with other bug tracking sofrware, preferably
of the open source kind. 
-- 
Muli Ben-Yehuda				    http://www.mulix.org/
[email-masked]:~$ sctrace strace /bin/foo  http://syscalltrack.sf.net/
Quis custodes ipsos custodiet?

---

From: Oleg Goldshmidt <[email-masked]>
Date: 23 Nov 2002 10:24:57 +0200

> suitable for such a situation? 

I find Bugzilla's interface a bit cumbersome, but then I am not a big
fan of complicated GUIs. It would fit the bill all right.

My favourite is still GNATS. It satisfies all the requirements you
listed. In addition, it has the *amazingly* useful feature that you
can send, cc, or forward an email to it, and it gets included in the
audit trail of the problem report specified. This means that if
something relevant pops up in an email discussion (as often happens in
my - and I suppose others' - practice) it is trivial to include it,
with comments. If you need to include a piece of code it is also
trivial to include, even without opening the bug report first.

I also got used to opening problem reports when I start some activity,
e.g. a new project. As I go along, there are often emails going in
different directions, sometimes questions and answers on a mailing
list, etc, and adding them to the database is as trivial and sending or
forwarding an email. Helped me more than once.

If Bugzilla can handle email in a similar way, I am not aware of
it. It is the most sorely lacking feature as far as I am concerned.

On Windows, there is the Tcl/Tk GNATS client (kinda clunky, but
usable), emacs client, various web interfaces.

Disadvantages.
 
- Basically ASCII only - no binary or proprietary attachments 
  etc. I don't think you will have luck with HTML either - it will
  show in the trail as HTML markup - hardly what you want. 

- Bugzilla *may* be more scalable. I never used GNATS for more than,
  say, 15 developers. Bugzilla is being used by large projects with no
  problems. Your project is small, but maybe you'll grow... ;-)

It's GNU software - you'll find it from http://www.gnu.org.

HTH,

-- 
Oleg Goldshmidt | [email-masked] 
========================================================
First binary search algorithm         - J. Mauchly, 1946        
First correct binary search algorithm - D.H.Lehmer, 1960

---

From: "Nadav Har'El" <[email-masked]>
Date: Sat, 23 Nov 2002 11:54:13 +0200

> suitable for such a situation? 

Yes, I have good experience of using bugzilla at my work (in addition to,
of course, using bugzilla in posting bugs in open source projects like
Redhat and Mozilla), and I would wholeheartedly recommend it.

Some other people at my work, for some strange reason, decided to try "php
bugtracker" instead of bugzilla. php bugtracker looks like a bugzilla clone,
but reportedly has many bugs and annoyances, so they are now considering
switching to bugzilla. So I will not recommend php bugtracker.

-- 
Nadav Har'El                        |    Saturday, Nov 23 2002, 18 Kislev 5763
[email-masked]             |-----------------------------------------
Phone: +972-53-245868, ICQ 13349191 |Linux is just like a wigwam: no Windows,
http://nadav.harel.org.il           |no Gates and an Apache inside.

---

From: "Tzahi Fadida" <[email-masked]>
Date: Sat, 23 Nov 2002 05:41:06 +0200

my 2 nis:
you can always write your own in php(as if :), If you can afford the time.
or even do a little access like programming (don't know if there is an equivalence in
linux).
another option is to treat bugs as project goals. or like they often do in the army,
use outlook (or its equivalence) task schedueling to forward bugs and recieve
confirmation
on closed issues from your programmers.

on the other hand, open source projects are different from "normal" projects in that
they are decentralized, and
the programmers are often transient, so you need to keep the bugs in one place. but
you need to make
sure that there won't be overlapping bug handling by the programmers. i.e: you will
also want to see who
is going to take care of what. in the decentralized case, i guess that a programmer
takes a bug from the basket and if he quits or don't want to do or can't do the bug
he can return it to the basket.

and last, searching sourceforge for "bug report" gives some programs in the fairly
stable stage:
TUTOS
phpBugTracker
zenTrack
IssueTrackerProduct

didn't check any of them, but they look promising.

* - * - *
Tzahi Fadida
[email-masked]
Technion Email: [email-masked]
My Cool Site: HTTP://WWW.My2Nis.Com
* - * - * - * - * - * - * - * - * - *

WARNING TO SPAMMERS:  see at http://members.lycos.co.uk/my2nis/spamwarning.html

> -----Original Message-----
> From: Muli Ben-Yehuda [mailto:[email-masked]]
> Sent: Saturday, November 23, 2002 1:18 AM
> To: [email-masked]
> Subject: Re: [hackers-il] Your recommendation for a bug-tracking database
>
>
> > - Linux-based server
> >   under Windows 2000
> > - Small group (4 programmers, 2 software testers)
> >   tracked (i.e. it may be evil closed proprietary software)
> >
> To unsubscribe from this group, send an email to:
> [email-masked]
>
>
>
> Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
>
>
>
>
>

---

From: Shlomi Fish <[email-masked]>
Date: Sat, 23 Nov 2002 17:58:17 +0200 (IST)

> and last, searching sourceforge for "bug report" gives some programs in the fairly

Also check:

http://directory.google.com/Top/Computers/Software/Configuration_Management/Bug_Tracking/

And its "Free" directory.

Regards,

	Shlomi Fish

> WARNING TO SPAMMERS:see at http://members.lycos.co.uk/my2nis/spamwarning.html
>
> > > - Clients run Linux.It would be nice to be able to use clients also
> > > under Windows 2000
> > [email-masked]:~$ sctrace strace /bin/foohttp://syscalltrack.sf.net/

----------------------------------------------------------------------
Shlomi Fish        [email-masked]
Home Page:         http://t2.technion.ac.il/~shlomif/
Home E-mail:       [email-masked]

"Let's suppose you have a table with 2^n cups..."
"Wait a second - is n a natural number?"

---

From: Sagi Bashari <[email-masked]>
Date: Sun, 24 Nov 2002 14:14:35 +0200

>suitable for such a situation? 

Try mantis (http://mantisbt.sourceforge.net/).

I've been using it for few months now with small project (4 user 
accounts, internal).

I choose it over bugzilla and others because it's simple (my boss can 
easily use it), it is written in PHP and uses MySQL for database (so I 
can easily customize it if I want to) and the code is pretty clean.

Until now, I have no complaints, except that if you turn on email 
reporting, it sends an email about every modification to all the team 
members (which can get pretty annoying) but that should be easy to fix.

Sagi