Subject: Joel Spokesly - leaking abstractions

From: "Arik Baratz" <[email-masked]>
Date: Tue, 12 Nov 2002 13:15:02 +0200

"In teaching someone about COM programming, it would be nice if I could just teach them how to use the Visual Studio wizards and all the code generation features, but if anything goes wrong, they will not have the vaguest idea what happened or how to debug it and recover from it. I'm going to have to teach them all about IUnknown and CLSIDs and ProgIDS and ... oh, the humanity!"

I so identify.

http://www.joelonsoftware.com/articles/LeakyAbstractions.html

Arik Baratz
System Engineer

Office:
13 Hasadna St.		Tel:   +972 (9)  743-9250 ext. 114
Raa'nana 43661		Fax:   +972 (9)  743-9251
ISRAEL			Cell:  +972 (55) 987-617

This email may contain confidential information. You may not deliver this message to anyone without my consent.

If this message is not intended for you, Please destroy this message and kindly notify me by replying this mail.

Anything in this message that do not relate to the official business of Vidius is my own responsibility.

---

From: Gilad Ben-Yossef <[email-masked]>
Date: Tue, 12 Nov 2002 16:44:35 +0200

> http://www.joelonsoftware.com/articles/LeakyAbstractions.html

I never read anything in my life that defined the problem so well and 
then went on to take the exact opposite conclusion from me sp much as 
this one.

He seems to be wishing for a world where you never ever need to look 
behind the covers to find out how something works. A world of little 
black perfect boxes - or maybe not so perfect but you're not supposed to 
look inside and change them anyway because it'll be "waste of time". He 
seems to be wishing to live in a world where learning to click "OK" in 
the wizard will be all you need or allowed to do.

The problem with people like him is they mistake the good habbit of 
writing as if you don't know what lies behind the curtain to actually 
not knowing what lies behind the curtain. "You shouldn't be messing with 
*that*", I can hear him say inside my head. How very Microsoftish of him :-)

I don't think they are leaky abstractions. They are simply what they are 
- abstractions, a mental facility to make it simpler for you to think of 
complex things, not hide the complexity away.

Gilad.