Subject: RE: [hackers-il] Re: GCC's statement expressions

From: Arik Baratz <[email-masked]>
Date: Wed, 9 Jan 2002 17:37:12 +0200

An rvalue MUST resolve to a value.

e.g. a=3

An lvalue MUST resolve to an address, but MAY resolve to a value as well.

e.g. if (a==(b=3)) break; --> b is the lvalue of the assignment 'b=3' but
also resolves to 3.
e.g. in basic you can use str=mid(s,3,5) and also mid(s,3,5)=str

-- Arik

-----Original Message-----
From: Tzafrir Cohen [mailto:[email-masked]]
Sent: Wed, January 09, 2002 5:30 PM
To: [email-masked]
Subject: RE: [hackers-il] Re: GCC's statement expressions

On Wed, 9 Jan 2002, Chen Shapira wrote:

> whats' an lvalue?

Left/Right value

In an assignment expression you have:

  lvalue = rvalue

-- 
Tzafrir Cohen                        /"\
mailto:[email-masked]        \ /  ASCII Ribbon Campaign
Taub 229, 972-4-829-3942,             X   Against  HTML  Mail
http://www.technion.ac.il/~tzafrir   / \

To unsubscribe from this group, send an email to:
[email-masked]

Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/ 

******************************************************************
This mail message was scanned by Vidius Port Authority 
(Enterprise Edition) for unauthorized confidential and 
proprietary information.

http://www.vidius.com
******************************************************************

---

From: Adi Stav <[email-masked]>
Date: Wed, 9 Jan 2002 21:14:55 +0200

> An lvalue MUST resolve to an address, but MAY resolve to a value as well.

Is that necessarily so? A register variable cannot have its address
taken but is an lvalue. Which lvalue does not resolve to a value?