Subject: Suggestion

From: Moshe Zadka <[email-masked]>
Date: Sat, 6 May 2000 17:49:05 +0300 (IDT)

How about each of us list topics he or she would like to know more about?
If there is a subject which has interest and there is someone to teach it,
we could have a nice lecture.

Personally, I'd like to hear about

* webdav
* advanced scheme
* programming languages I haven't heard about it

--
Moshe Zadka <[email-masked]>
http://www.oreilly.com/news/prescod_0300.html
http://www.linux.org.il -- we put the penguin in .com

---

From: [email-masked]
Date: Sat, 6 May 2000 21:59:49 +0300

> * programming languages I haven't heard about it

Same here with the following additions:

* OS internals (any OS)
* Compilers
* neat programming techniques - how to make a language do things it was never
 meant to do.
* 101 ways to write a webserver / put a fortune in your sig 
* lambda calculus

I can give a short talk about the Hurd if anyone is interested.

--
Chen Shapira	Web Developer and Linux Activist
The algorithm for finding the longest path in a graph is NP-complete.
For you systems people, that means it's *real slow*.

---

From: [email-masked]
Date: Sun, 07 May 2000 15:41:06 -0000

Well, lets see what I am able to talk about in near future:

> > Personally, I'd like to hear about
me, first lecture (at least for me), June
> > * programming languages I haven't heard about it
APL? Ada? J? 

> Same here with the following additions:
Is it ethical for me to speak of Linux kernel?:) Who gives the damn to
ethics:))) you got it. Second lecture.
> * Compilers
me, but gmayer will do it far better
> * neat programming techniques - how to make a language do things it
was never
Object oriented programming in Bourne shell? CPS in Java? Third
lecture.
> * 101 ways to write a webserver / put a fortune in your sig

up to implementing /proc/signature or something like 
mount sigs /sigs -t sigfs? Fourth lecture. 

> * lambda calculus

we have to invite gmayer. He is the Knight of bloody Lambda Calculus.

* inefficiencies of C++. Fifth one.

* "having sex" with gdb and ld. Sixth one.

* jazz basics and how we can apply it to programming.

* lockpicking for dummies.

TBA
Of course, I am talking about random values of 1-6.

---

From: Moshe Zadka <[email-masked]>
Date: Mon, 8 May 2000 07:27:45 +0300 (IDT)

> APL? Ada? J? 

APL! Definitely APL

> * inefficiencies of C++. Fifth one.

Ummm....that one is to damn easy