Subject: How to exploit 1MB data structures?

From: Omer Zak <[email-masked]>
Date: Tue, 12 Feb 2002 01:38:25 +0200 (IST)

The future computers will have terabytes of memory (mostly in disks, but
some in RAM).  They will be able to manipulate megabytes at the time
needed by yesterday's computers to manipulate single bytes.

I wonder how can all those extra bytes be harnassed. (AI anyone?)

Let's try to use 1MB to represent the string "The beep has booped".
The data structure will contain:
- The actual string itself
- How it was split into words
- Several regular expression matches on it (each time someone applies a
  regular expression to it, the match results are added to the data
  structure).
- Meanings of the words (not just pointers, the whole works!).
- References to the beep() function, its manpage and its source code
  (of course, annotated with comments).
- Constructors
- Destructors
- Treatises on the meaning of 'ee' and 'oo'.

                                             --- Omer
There is no IGLU Cabal.  The rules of the game in a terabyte environment
are completely different from the rules in the 4KB environment which was
the vogue when people were used to organize Cabals.
WARNING TO SPAMMERS:  see at http://www.zak.co.il/spamwarning.html

---

From: "Gilad Ben-Yossef" <[email-masked]>
Date: Tue, 12 Feb 2002 16:13:55 +0200

> - Treatises on the meaning of 'ee' and 'oo'.

I disagree. The problem with not keeping all this information in the string is not that takes a lot of place, but rather that you need to duplicate it. That is, there are many more strings with the beep word, and so keping the man page to the beep function in-string will duplicate the data. The problem here is NOT space, but rather the need to sync the various copies.

Gilad.

-- 
Gilad Ben-Yossef <[email-masked]>
Tel: +972(9)9717330 | Fax: +972(9)9717334   | Cel: +972(54)756701
Kagoor Networks ltd | http://www.kagoor.com |