Subject: Some Other Rules of Open-Source Programming

From: Shlomi Fish <[email-masked]>
Date: Wed, 12 Dec 2001 20:49:07 +0200 (IST)

* If you don't work on your project, chances are that no-one will.

* Your first releases are always inherently broken.

And a correction:

* Don't whine unless you intend to implement it yourself.

Regards,

	Shlomi Fish

----------------------------------------------------------------------
Shlomi Fish        [email-masked]
Home Page:         http://t2.technion.ac.il/~shlomif/
Home E-mail:       [email-masked]

"Let's suppose you have a table with 2^n cups..."
"Wait a second - is n a natural number?"

---

From: mulix <[email-masked]>
Date: Wed, 12 Dec 2001 20:49:19 +0200 (IST)

> * If you don't work on your project, chances are that no-one will.

absolutely correct.

> * Your first releases are always inherently broken.

not always, sometime, and that's a *good* thing, because the
alternative is to never release any code, thinking it's not good enough.

release early, release often, release small.

> * Don't whine unless you intend to implement it yourself.

how about "don't whine, implement"?
-- 
mulix

http://vipe.technion.ac.il/~mulix/
http://syscalltrack.sf.net/

---

From: Shlomi Fish <[email-masked]>
Date: Wed, 12 Dec 2001 21:24:35 +0200 (IST)

> release early, release often, release small.

How about:

* Your first releases can always be improbed upon.

> how about "don't whine, implement"?

I prefer the more verbose version.

Regards,

	Shlomi Fish

> To unsubscribe from this group, send an email to:
> [email-masked]
>
>
>
> Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
>
>