Subject: RE: [hackers-il] Re: GCC's statement expressions

From: Arik Baratz <[email-masked]>
Date: Wed, 9 Jan 2002 18:20:13 +0200

I think that in Pascal you cannot do a:=b:=c but I'm not sure. All I said
it's not a requirement in a programming language to have the lvalue resolve
to a value. I was not addressing C/++ specifically.

An address could be a register. Let's just change the terminology in my
argument from 'address' to 'location for data storage' and it works.

-- Arik

-----Original Message-----
From: Adi Stav [mailto:[email-masked]]
Sent: Wed, January 09, 2002 9:15 PM
To: [email-masked]
Subject: Re: [hackers-il] Re: GCC's statement expressions

On Wed, Jan 09, 2002 at 05:37:12PM +0200, Arik Baratz wrote:
> 
> An rvalue MUST resolve to a value.
> 
> e.g. a=3
> 
> An lvalue MUST resolve to an address, but MAY resolve to a value as well.

Is that necessarily so? A register variable cannot have its address
taken but is an lvalue. Which lvalue does not resolve to a value?

To unsubscribe from this group, send an email to:
[email-masked]

Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/ 

******************************************************************
This mail message was scanned by Vidius Port Authority 
(Enterprise Edition) for unauthorized confidential and 
proprietary information.

http://www.vidius.com
******************************************************************

---

From: Adi Stav <[email-masked]>
Date: Wed, 9 Jan 2002 22:22:38 +0200

> to a value. I was not addressing C/++ specifically.

Ah, I see. It's been quite some time since I last touched Pascal. 
You could just say Pascal assignments don't return anything, either 
lvalue or rvalue.