Subject: RE: [hackers-il] Summary of a Bash Lecture

From: Chen Shapira <[email-masked]>
Date: Thu, 2 Nov 2000 10:52:16 +0200

> Say
> 
> x="moshe"
> while 1:
> 	x=x+x
> 
> will fail pretty quickly. 
> But you can't really claim it's buggy...
> Not until you get a MemoryError

Many things that are problematic aren't really bugs, but you still want to
catch them. This shouldn't prevent compilation, just pop a small warning.
Same with infinite loops.

Like lint points out "if x=y ..." as warning.
It can be right, but a program that says "thats wierd, are you sure" can
help.
Especially beginners that in 9 out of 10 cases use a bug not a feature.

---

From: Moshe Zadka <[email-masked]>
Date: Thu, 2 Nov 2000 11:02:57 +0200 (IST)

> Especially beginners that in 9 out of 10 cases use a bug not a feature.

Well, my point was that building long strings is a very natural thing.
In what situation do you want to get a warning? On using too much memory?
It's easier to set soft limits, in that case.
--
Moshe Zadka <[email-masked]> -- 95855124
http://advogato.org/person/moshez