Subject: Re: [hackers-il]

From: "praveenjohri" <[email-masked]>
Date: Thu, 02 May 2002 15:17:40 +0530

hi ofir ,
as u said to copy the code into my program i had this idea before but there is a problem that
i have to manually edit the filter code and again and again whenever i am changing the filter criteria
and have to recompile the program again and again.

what my project is to make a tapping device with
GUI user interface where user can specify the filter
grammer every time before running the program
but if some one have to specify the filter into the struct sock_filter everytime then the fecility to
user to specify the filter will not be there which
will temper the objective of my project.
i want to have something like what tcpdump does
i.e. it lets the user set the filter and produces the bpf code and set the filter...

please,tell me the way how to do it

with regards

pravee johri

Get Your Private, Free E-mail from Indiatimes at http://email.indiatimes.com

 Buy Music, Video, CD-ROM, Audio-Books and Music Accessories from http://www.planetm.co.in

---

From: Tzafrir Cohen <[email-masked]>
Date: Thu, 2 May 2002 13:56:33 +0300 (IDT)

Hi

> please,tell me the way how to do it

I believe you have the wrong address. This is not the private address of
some Ofir, but a public mailing list. It is intended to discuss hacking of
code  and philosophical discussions.

If you intented to post to a mailing list you should probably post to a
more technical list, such as your local LUG's list or some kernel-related
list.

Regards

-- 
Tzafrir Cohen
mailto:[email-masked]
http://www.technion.ac.il/~tzafrir