Subject: RE: [hackers-il] Game Theory, RPGs and Real-Life

From: Chen Shapira <[email-masked]>
Date: Thu, 21 Mar 2002 12:58:58 +0200

> The number of options at any given situation is practically infinite.
> While a good game master is determinstic and knows exactly 
> what happens
> for any given situation the players' reach and for every 
> action they take,
> there is still a very large number of situations which can be reached.
> 
> Game Theory models work on a finite set of strategies, or such that
> follow a certain pattern. This is not the case for a 
> role-playing game.

Hmm, but maybe we can reduce infinte options into a finite number of groups,
and then apply the game theory results?

In your example, there are infinite options, but we can group them into:

1. Manage to open the door
2. Give up and go somewhere else
3. Stay there and wait for something to happen

Or if you think that they'll manage to open the door anyway (theres no other
choice), we can group options by tactics:

1. Ask for help
2. Use a tool
3. Use a specific skill
4. Use force

In any case, we can probably come up with a finite list of general cases
that are more interesting to us.

---

From: Shlomi Fish <[email-masked]>
Date: Thu, 21 Mar 2002 13:07:59 +0200 (IST)

> 3. Stay there and wait for something to happen

But they are still different strategies. If the characters try to open the
door in manner A, and fail, than the enemy behind the door may become
aware of their presence. So, the choice here is actually quite critical.

Regards,

	Shlomi Fish

> To unsubscribe from this group, send an email to:
> [email-masked]
>
>
>
> Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
>
>

----------------------------------------------------------------------
Shlomi Fish        [email-masked]
Home Page:         http://t2.technion.ac.il/~shlomif/
Home E-mail:       [email-masked]

"Let's suppose you have a table with 2^n cups..."
"Wait a second - is n a natural number?"