Subject: RE: language issues ( was RE: [hackers-il] [[email-masked] .IL: Shimon Schocken on Tu esday 05/06/2001] )

From: Chen Shapira <[email-masked]>
Date: Tue, 10 Apr 2001 12:50:50 +0200

> -----Original Message-----
> From: Omer Musaev 
> Sent: Tuesday, April 10, 2001 12:34 PM
> To: [email-masked]'

> However, in some cases case sensitivity can help. 
> For example consider a following convention:
>  we have variables fsize, bsize and ssize, which carry sizes of 
>  various variable size structures. Constants FSIZE, BSIZE and 
> SSIZE hold
>  minimal size of appropriate structures.
> 
> Here, case sensitivity is a win.

A technical win. Because when I remember names I remember them by sounds, I
think that most of us do too. So having 2 variables with the same sound and
diffrent meaning will make the program harder to learn. 
What's wrong with MIN_FSIZE? 

> People who use Pascal for serious programming fall into a fatal trap.

Pascal has its problems, but every language has those.
We do OO in C, I try to write efficient and clean code in VB, and some of us
write finite automata in PS.

The problem in pascal isn't what it doesn't support. C doesn't support
lambda and we can live with that. The main problem is that there's no good
reason to do pascal anymore.
C is used for portability. Java for a wide library, OO support and some hype
value, VB is used for its ease of use. 

One thing pascal may still be good for is "Intro to CS" in first year
courses. 
At least no worse than anything else.
IMO there's no good language for that (maybe Python?), mostly because the
requisites aren't well defined enough.

---

From: Omer Musaev <[email-masked]>
Date: Tue, 10 Apr 2001 12:58:24 +0200

> From: Chen Shapira 
> Sent: Tuesday, April 10, 2001 12:51 PM
> Subject: RE: language issues ( was RE: [hackers-il]
> [[email-masked] .IL: Shimon Schocken on Tu esday 05/06/2001] )
> 
> 
> 
> 
> different meaning will make the program harder to learn. 

Hm. Well, my example was somewhat exaggerated. However, any convention is
better than to have fsize, bsize, MIN_FSIZE _AND_ BSIZE.

Take a note that we use CAPITAL NAMES for constants for granted, and once it
was not 
in practice ( ALL VARIABLES WERE CAPITALS AND YOU HAD A IDENTIFICATION
DIVISION SOMEWHERE )

> The problem in Pascal isn't what it doesn't support. C doesn't support
> reason to do Pascal anymore.

A good point. 
However, that sentence was issued at 1981 (it was part of citation),
when Pascal was used widely and was used for serious programming.

> One thing Pascal may still be good for is "Intro to CS" in first year
> courses. 

I second that.
I learned intro to CS in Java, however, lecturer had used all his 
material from Pascal course. That was annoying. His motto was something like

"inheritance is bad, procedural programming is very, very good".