Subject: "Ways to do it" according to the Programming Languages of the World

From: Shlomi Fish <[email-masked]>
Date: Wed, 8 May 2002 23:00:09 +0300 (IDT)

Just fresh from my press: a joke by yours truly. I hope you enjoy it.
Deltas, suggestions, comments, discussion, flames, corrections, etc. are
more than welcome. But let's not escalate it into a language war. (it's
just a joke)

-------

Perl - There's more than one way to do it.

C++ - There are 5 ways to do it, 3 out of which are not supposed to work.

Visual Basic - The only way to do it is to use a third party component.

ANSI C - There is usually one way to do it, but there's more than one way
to
optimize it.

Java - There's barely one way to do it.

Python - There's only one way to do it. The one true way of doing it.

COBOL - The only way to do it is to use something else.

Common LISP - There is a infinite series of ways to do it, increasing in
elegance, and decreasing in legibility.

Scheme - You have to chart either one of the ways to do it.

Haskell - You can think of any number of ways to do it, but only one
will have a reasonable time or space complexity.

HTML - There are many ways to do it. Most of them should be avoided at all
costs, and the other ones should better be precossed with something else.

The C Preprocessor - There's not supposed to be a way to do it.

Bash - There are several ways to do it. Now one has to find a way to
decide
which way to do it.

C Shell - The only way to do it does not work.

-----------

Regards,

	Shlomi Fish

----------------------------------------------------------------------
Shlomi Fish        [email-masked]
Home Page:         http://t2.technion.ac.il/~shlomif/
Home E-mail:       [email-masked]

"Let's suppose you have a table with 2^n cups..."
"Wait a second - is n a natural number?"

---

From: Eliran <[email-masked]>
Date: Thu, 9 May 2002 18:10:55 +0300

Hello !

I have just got the book: "A Quarter Century of UNIX" by Addison Wesley,
and it seems they have this code on the be 1st page of the book, the code looks like this :

<code>
/* You atr not expected to understand this */
if (rp -> p_flag & SSWAP) {
	rp -> p_flag =& ~SSWAP;
	aretu (u.u_ssav);
}
</code>

and later there is:

<something>
lines 2240-2243; Sixth Edition(C) Western Electric Co.;
the comment is line 2238.
</something>

What do you think it means ?

Regards,
Eliran
-- 
		<a href="http://eg-site.tripod.com">Eliran</a>

Someone sent me a postcard picture of the earth.  On the back it
said, "Wish you were here."
						-- Stephen Wright

---

From: Nimster <[email-masked]>
Date: Thu, 09 May 2002 20:45:01 +0200

Hey,

This (and "values of b will give rise to dom!") are famous "easter eggs" or
rather funny documentation highlights which appeared in different UNIX
releases and made quite a myth.
Check this: http://cm.bell-labs.com/cm/cs/who/dmr/odd.html and
http://www.tmk.com/ftp/humor/computer-error-messages.txt out for more of
these silly quotes.

-Nimster

----- Original Message -----
From: "Eliran" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, May 09, 2002 5:10 PM
Subject: [hackers-il] A Quarter Century of UNIX -- Hidden messages ?

> To unsubscribe from this group, send an email to:
> [email-masked]
>
>
>
> Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
>
>

---

From: Shlomi Fish <[email-masked]>
Date: Thu, 9 May 2002 21:17:07 +0300 (IDT)

> http://www.tmk.com/ftp/humor/computer-error-messages.txt out for more of

While not exactly "ancient" history, they remind me of the "use Perl;"
quote-list:

http://use.perl.org/quotes.txt

Lots of out-of-the-wall comments from Larry Wall. (pardon the pun)

Regards,

	Shlomi Fish

> Subject: A Quarter Century of UNIX -- Hidden messages ?
>
>
> > Hello !
> >

---

From: Adeyemo oluseyi <[email-masked]>
Date: Thu, 9 May 2002 18:47:48 -0700 (PDT)

Hi there,
      Please i need to become an hacker, and i didn't
have any programing techniques. How can you help me
out and let me be an hacker.
  I was about to start a programing class in which
everything about programing, c++, HTML, java script,
visual basis and all  the rest will be easy for me,and
to make this possible , imust make my payment of
$1,500 with credit card and which i cannot get unless
i contact you because you are the one that can have
such a thing in hand. Please help me so as to fulfill
my hacking vision.
   Thanks for co-oporation.
      OLUSEYI ADEYEMO
     
--- Shlomi Fish <[email-masked]> wrote:
> costs, and the otherPOST
http://us.f204.mail.yahoo.com/ym/Compose?YY=83397
HTTP/1.0 ones should better be precossed
> with something else.
> "Wait a second - is n a natural number?"

__________________________________________________
Do You Yahoo!?
Yahoo! Shopping - Mother's Day is May 12th!
http://shopping.yahoo.com

---

From: Oleg Goldshmidt <[email-masked]>
Date: 10 May 2002 18:08:30 +0300

> out and let me be an hacker.

http://www.tuxedo.org/~esr/faqs/hacker-howto.html

-- 
Oleg Goldshmidt | [email-masked] 
If it aint't broken it hasn't got enough features yet.

---

From: Oleg Goldshmidt <[email-masked]>
Date: 10 May 2002 18:20:58 +0300

> http://www.tuxedo.org/~esr/faqs/hacker-howto.html

Uh. I thought it would be a reasonable tongue-in-cheek reply, and 5
minutes later I get a 20-posting-long thread with a discussion of who
ESR is? I guess fetchmail (yes, that's what I use for popping my mail
every 5 minutes from the ISP) is playing tricks with me. Withdrawn,
with apologies. ;-)