Subject: RE: [hackers-il] Looking for Books (once again)

From: Omer Musaev <[email-masked]>
Date: Mon, 18 Nov 2002 18:31:14 +0200

' -----Original Message-----
' From: Nadav Har'El [mailto:[email-masked]]
' Sent: Monday, November 18, 2002 5:37 PM
' To: [email-masked]
' Subject: Re: [hackers-il] Looking for Books (once again)
' 
'

' Another one of my weird-one-line-code-signatures:
' echo '[q]sa[ln0=aln256%Pln256/snlbx] 
' sb3135071790101768542287578439snlbxq'|dc
' 

Wich reminds me of Life game implemented by Dr. Goldberg[1] in dc

Here it goes:

-----------------------
[The Game of Life in 'dc' -- Unix's beloved 'desk calculator'
]s.
[Programmer: Mayer Goldberg, 1997
]s.

[THE FUNCTIONS USED:
]s.
[   L                start the game of life
]s.
[   N                advance to next generation
]s.

46 0:C35 1:C[z0:T1:V0:V0;V1;V*d2:V2+0;T[[args != rows * cols]P10Pcq]sk!=k2;V
0[[rows = 0 or cols =
0]P10Pcq]sk=k2;V0:T[0;T1-0:T3;Fx;C0;T:B0;T0<k]sklkx]0:F 
[0 0:T0 2:T[0 1:TlKx10P0;T1+d0:T0;V>k]sk[2;T;BP2;T1+2:T1;T1+d1:T1;V>K]sKlkx]

1:F[[0q]sR0=R1]3:F[3;V1+3:V0dd4:V5:V6:V2;V0:T0;V1:T[1;T1-1:T1;V2:TlKx1;T0<k]
sk 
[2;T1-2:T0;T1-0:T6;Fx[[[1;C0;T:D4;V1+4:V3Q]sr3;T3=r0;C0;T:Dq]sr0;T;B0;C=r[[1
;C0
;T:D6;V1+6:Vq]sr3;T2=r3;T3=r0;C0;T:D5;V1+5:V]x]x2;T0<K]sKlkx2;V0:T[0;T1-d0:T
;D 
0;T:B0;T0<k]sklkx]4:F[6:T5:T[q]sR5;T0>R6;T0>R5;T0;V!>R6;T1;V!>R5;T0;V*6;T+d4
:T 
;B0;C=R3;T1+3:T]5:F[0
3:T1;T1-2;T1-5;Fx1;T1-2;T5;Fx1;T1-2;T1+5;Fx1;T2;T1-5;Fx1
;T2;T1+5;Fx1;T1+2;T1-5;Fx1;T1+2;T5;Fx1;T1+2;T1+5;Fx]6:F[4;Fx
[Generation ]P3;Vps.
[  The number of cells that survived is ]P6;Vps.
[  The number of cells that were born is ]P4;Vps.
[  The number of cells that died is ]P5;Vps.
1;Fx]sN[0;Fx[The initial board]P10P1;Fx6;Fx]sL

0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
1 1 1 0 0 0
0 0 1 0 0 0
0 1 0 0 0 0
6 6
lLx

-----------------------

' 
' -- 
' Nadav Har'El                        |      Monday, Nov 18 
' 2002, 13 Kislev 5763
' [email-masked]             
' |-----------------------------------------
' Phone: +972-53-245868, ICQ 13349191 |A language is a dialect 
' with an army.
' http://nadav.harel.org.il           |
' 
' To unsubscribe from this group, send an email to:
' [email-masked]
' 
'  
' 
' Your use of Yahoo! Groups is subject to 
http://docs.yahoo.com/info/terms/

---

From: Chen Shapira <[email-masked]>
Date: Tue, 19 Nov 2002 10:32:13 +0200

> Well i have some books, but i ain;t never gonna sell :)
> anyway, i don't see why you can't get them in the library:
> for stochastic processes you have:
> Prof micha yadin(rip) (hebrew) "stochastic models"
> Ross. S., Introd.  To Probability Models

Some of these books (especially silverberg and sipser) have very few copies
in the library and many students who want to read them. 

I got Ross's book in the library, though. Thanks for the recommendation, it
seems very good indeed.
 
> operating systems:
> I personally like silberschatz "applied operating system 
> concepts", with lots of java
> examples.

Java examples?
The other OS books I saw had very few examples, and lots of theory.

> linear programming, which includes some queue theory and game theory:
> I personally think the best books written for this, are the 
> openU translated books
> of "deterministic models" F s. Hillier and Lieberman.

Thanks.