Subject: language comparision

From: Chen Shapira <[email-masked]>
Date: Wed, 5 Dec 2001 20:56:16 +0200

Hi,

Found a nice article comparing diffrent aspects of performance between 7
programming languages (C, C++, Java, Perl, Python, ReXX, TCL). used for
solving a single program. Multiple programmers were used for each language.

The results can't be conclusive, since only one type of program was used,
but it still makes a good read.

One of the more interesting results were that the diffrences between
different programmers in the same language were greater than diffrences
between languages.
But ofcourse we knew this all along.

http://wwwipd.ira.uka.de/~prechelt/Biblio/Biblio/jccpprt_computer2000.pdf

Thanks,
Chen.

---

From: Shlomi Fish <[email-masked]>
Date: Thu, 6 Dec 2001 04:24:08 +0200 (IST)

> solving a single program. Multiple programmers were used for each language.

I believe I linked to it first, back in August 2000:

Check:

http://groups.yahoo.com/group/hackers-il/message/364

But what the heck.

Regards,

	Shlomi Fish

> To unsubscribe from this group, send an email to:
> [email-masked]
>
>
>
> Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
>
>

----------------------------------------------------------------------
Shlomi Fish        [email-masked]
Home Page:         http://t2.technion.ac.il/~shlomif/
Home E-mail:       [email-masked]

If:
1. A is A
2. A is not not-A
does it imply that
1. B is B
2. B is not not-B